ViPNet Administrator

Общая информация

В этом разделе

О документе

О программе

Системные требования

Комплект поставки

Обратная связь

Содержание

О документе

Общие сведения

Установка программного обеспечения ViPNet Administrator

Начало работы

Обновление программного обеспечения ViPNet Administrator

Удаление программного обеспечения ViPNet Administrator

Возможные неполадки и методы их устранения

Региональные настройки

Внешние устройства


О документе

В данном документе подробно описывается процесс установки и первичной настройки компонентов программного обеспечения ViPNet Administrator. Приводятся схемы установки, даются рекомендации по размещению компонентов. Также представлена информация об обновлении программ, входящих в состав ViPNet Administrator, приведены решения возможных проблем.

Если ранее в вашей сети использовалось программное обеспечение ViPNet Administrator версии 3.2.x, и вы переходите на использование ПО ViPNet Administrator версии 4.х, вам необходимо также ознакомиться с документом «ViPNet Administrator. Руководство по обновлению с версии 3.2.x на версию 4.х».

В этом разделе:

Для кого предназначен документ

Соглашения документа


Для кого предназначен документ

Настоящий документ предназначен для администраторов, осуществляющих установку, обновление и первичную настройку программного обеспечения ViPNet Administrator®.


Соглашения документа

Ниже перечислены соглашения, принятые в этом документе для выделения информации.

Обозначения, используемые в примечаниях

Обозначение | Описание
 | Внимание! Указывает на обязательное для исполнения или следования действие или информацию.
 | Примечание. Указывает на необязательное, но желательное для исполнения или следования действие или информацию.
 | Совет. Содержит дополнительную информацию общего характера.

Обозначения, используемые для выделения информации в тексте

Обозначение | Описание
Название | Название элемента интерфейса. Например, заголовок окна, название поля, кнопки или клавиши.
Клавиша+Клавиша | Сочетание клавиш. Чтобы использовать сочетание клавиш, следует нажать первую клавишу и, не отпуская ее, нажать вторую клавишу.
Меню > Подменю > Команда | Иерархическая последовательность элементов. Например, пункты меню или разделы на панели навигации.
Код | Имя файла, путь, фрагмент текстового файла (кода) или команда, выполняемая из командной строки.


О программе

ПО ViPNet Administrator® предназначено для администрирования сетей ViPNet и состоит из двух компонентов:

  • ViPNet Центр управления сетью (ЦУС).
  • ViPNet Удостоверяющий и ключевой центр (УКЦ).

Программа ViPNet Центр управления сетью предназначена для формирования структуры защищенной сети ViPNet, настройки параметров сетевых узлов, регистрации пользователей на сетевых узлах и управления объектами сети.

Программа ViPNet Удостоверяющий и ключевой центр предназначена для издания и обслуживания сертификатов ключа проверки электронной подписи. Она выполняет функции удостоверяющего центра и предоставляет ключи, необходимые для работы в сети ViPNet.


Системные требования

Для установки программ, входящих в состав ПО ViPNet Administrator, компьютеры должны удовлетворять ряду требований.

Компьютер, на который будет установлено несколько программ ViPNet Administrator, должен соответствовать максимальным требованиям из числа указанных.

В этом разделе:

ViPNet Центр управления сетью

ViPNet Удостоверяющий и ключевой центр


ViPNet Центр управления сетью

В этом разделе:

Серверное приложение

Клиентское приложение


Серверное приложение

Требования к аппаратному обеспечению компьютера для установки серверного приложения ViPNet Центр управления сетью:

  • Процессор — Intel Core 2 Quad или другой схожий по производительности x86‑совместимый процессор с количеством ядер 4 и более.
  • Объем оперативной памяти — не менее 4 Гбайт.

Примечание. При большом количестве узлов и связей в сети ViPNet рекомендуется использовать более мощный компьютер:

  • Процессор — Intel Core i7 или другой схожий по производительности x86-совместимый процессор с количеством ядер 8 и более.
  • Объем оперативной памяти — не менее 16 Гбайт.
  • Редакция Microsoft SQL Server выше, чем Express Edition.

  • Свободное место на жестком диске — не менее 20 Гбайт.
  • Операционная система — Windows 7 (32/64-разрядная), Windows Server 2008 R2 (64-разрядная), Windows 8 (32/64-разрядная), Windows Server 2012 (64-разрядная), Windows 8.1 (32/64-разрядная), Windows Server 2012 R2 (64-разрядная), Windows 10 (32/64-разрядная).

    Для операционной системы должен быть установлен самый последний пакет обновлений.

  • При использовании Internet Explorer — версия 8 или выше.

Примечание. Перед установкой серверного приложения ViPNet Центр управления сетью убедитесь, что на вашем компьютере в разделе Программы и компоненты > Включение или отключение компонентов Windows включен компонент Возможности .Net Framework 3.5.

Для установки и функционирования серверного приложения ViPNet Центр управления сетью необходимо следующее программное обеспечение сторонних производителей:

  • На компьютере должны быть установлены следующие приложения:
    • Microsoft .NET Framework версии 4.6.2 (программная платформа). Поставляется в комплекте.
    • Microsoft Visual C++ 2010 Redistributable Package (набор компонентов среды выполнения библиотек Visual C++).

    Указанные приложения включены в комплект поставки программного обеспечения ViPNet Центр управления сетью.

  • Для размещения базы данных на компьютере с серверным приложением или на другом компьютере, доступном по сети, должна быть установлена система управления базами данных (СУБД). Поддерживаются следующие версии СУБД:
    • Microsoft SQL Server 2008 SP3 и выше.
    • Microsoft SQL Server 2008 R2 SP1 и выше.
    • Microsoft SQL Server 2012.
    • Microsoft SQL Server 2014 (рекомендуется).

    Редакция указанных СУБД может быть любой, в том числе и Express Edition. В комплект поставки программного обеспечения ViPNet Центр управления сетью включена СУБД Microsoft SQL Server 2014 Express. При необходимости она может быть автоматически установлена вместе с серверным приложением.

Внимание! В процессе эксплуатации программы ViPNet Центр управления сетью необходимо отслеживать выпуск обновлений безопасности для указанного ПО Microsoft и своевременно их устанавливать.


Клиентское приложение

Требования к аппаратному обеспечению компьютера для установки клиентского приложения ViPNet Центр управления сетью:

  • Процессор — Intel Core 2 Duo или другой схожий по производительности x86‑совместимый процессор с количеством ядер 2 и более.
  • Объем оперативной памяти — не менее 1 Гбайт (при использовании 64-разрядных версий ОС Microsoft Windows — не менее 2 Гбайт).
  • Свободное место на жестком диске — не менее 1 Гбайт.
  • Операционная система — Windows 7 (32/64-разрядная), Windows Server 2008 R2 (64-разрядная), Windows 8 (32/64-разрядная), Windows Server 2012 (64-разрядная), Windows 8.1 (32/64-разрядная), Windows Server 2012 R2 (64-разрядная), Windows 10 (32/64-разрядная).

    Для операционной системы должен быть установлен самый последний пакет обновлений.

  • При использовании программы Internet Explorer — версия 11.

Примечание. Перед установкой серверного приложения ViPNet Центр управления сетью убедитесь, что на вашем компьютере в разделе Программы и компоненты > Включение или отключение компонентов Windows включен компонент Возможности .Net Framework 3.5.

Для установки и функционирования клиентского приложения ViPNet Центр управления сетью на компьютере должно быть установлено следующее программное обеспечение сторонних производителей:

  • Microsoft .NET Framework версии 4.6.2 (программная платформа).
  • Microsoft Visual C++ 2010 Redistributable Package (набор компонентов среды выполнения библиотек Visual C++).

Указанные приложения включены в комплект поставки программного обеспечения ViPNet Центр управления сетью.

Внимание! В процессе эксплуатации программы ViPNet Центр управления сетью необходимо отслеживать выпуск обновлений безопасности для указанного ПО Microsoft и своевременно их устанавливать.


ViPNet Удостоверяющий и ключевой центр

Требования к компьютеру для установки программы ViPNet Удостоверяющий и ключевой центр:

  • Процессор — Intel Core 2 Duo или другой схожий по производительности x86‑совместимый процессор с количеством ядер 2 и более.
  • Объем оперативной памяти — не менее 1 Гбайт (при использовании 64-разрядных версий ОС Microsoft Windows — не менее 2 Гбайт).
  • Свободное место на жестком диске — не менее 20 Гбайт.
  • Операционная система — Windows 7 (32/64-разрядная), Windows Server 2008 R2 (64-разрядная), Windows 8 (32/64-разрядная), Windows Server 2012 (64-разрядная), Windows 8.1 (32/64-разрядная), Windows Server 2012 R2 (64-разрядная), Windows 10 (32/64-разрядная).

    Для операционной системы должен быть установлен самый последний пакет обновлений.

  • При использовании Internet Explorer — версия 8 или выше.

Дополнительные требования:

  • Для возможности сохранения паролей пользователей в файлы на компьютере должен быть установлен виртуальный принтер Microsoft XPS Document Writer. Данный принтер по умолчанию присутствует в операционных системах Windows 7 SP1 (32/64-разрядная), Windows 8 (32/64-разрядная), Windows 8.1 (32/64-разрядная). Если используется одна из операционных систем Windows Server 2008 R2, Windows Server 2012 или Windows Server 2012 R2 SP1, виртуальный принтер следует устанавливать вручную.
  • При печати паролей пользователей ViPNet на ПИН-конвертах рекомендуется использовать:
    • Специализированные принтеры для печати ПИН-конвертов или аналогичные матричные принтеры модели OKI ML5100FB.
    • Стандартные четырехслойные ПИН-конверты с расширенным полем для секретной информации.


Комплект поставки

В комплект поставки программного обеспечения ViPNet Administrator входит:

  • Установочный файл серверного приложения ViPNet Центр управления сетью.
  • Установочный файл клиентского приложения ViPNet Центр управления сетью.
  • Приложения сторонних производителей, необходимые для работы компонентов программы ViPNet Центр управления сетью.
  • Установочный файл программы ViPNet Удостоверяющий и ключевой центр.
  • Документация в формате PDF:
    • «ViPNet Administrator. Руководство по установке».
    • «ViPNet Administrator. Руководство по обновлению с версии 3.2.x до версии 4.х».
    • «ViPNet Administrator. Руководство по миграции программного обеспечения на другой компьютер».
    • «ViPNet Administrator. Быстрый старт».
    • «ViPNet Administrator. Лицензионные соглашения на компоненты сторонних производителей».
    • «ViPNet Центр управления сетью. Руководство администратора».
    • «ViPNet Удостоверяющий и ключевой центр. Руководство администратора».
    • «ViPNet CSP. Руководство пользователя».
    • «Развертывание сети под управлением ViPNet Administrator 4.х. Руководство администратора».
    • «Новые возможности ViPNet Administrator. Приложение к документации ViPNet».
    • «Основные термины и определения. Приложение к документации ViPNet».
    • «Классификация полномочий. Приложение к документации ViPNet».
    • «Печать сертификатов. Приложение к документации ViPNet».

Примечание. Список необходимых для работы ЦУСа приложений сторонних производителей см. в разделе Системные требования.


Обратная связь

Дополнительная информация

Сведения о продуктах и решениях ViPNet, распространенные вопросы и другая полезная информация собраны на сайте ОАО «ИнфоТеКС»:

  • Веб-портал документации ViPNet.
  • Описание продуктов ViPNet.
  • Информация о решениях ViPNet.
  • Сборник часто задаваемых вопросов (FAQ).
  • Форум пользователей продуктов ViPNet.

Контактная информация

С вопросами по использованию продуктов ViPNet, пожеланиями или предложениями свяжитесь со специалистами ОАО «ИнфоТеКС». Для решения возникающих проблем обратитесь в службу технической поддержки.

  • Техническая поддержка для пользователей продуктов ViPNet: hotline@infotecs.ru.
  • Форма запроса в службу технической поддержки.
  • Консультации по телефону для клиентов, имеющих расширенный уровень технического сопровождения:

    8 (495) 737-6192,

    8 (800) 250-0260 — бесплатный звонок из любого региона России (кроме Москвы).

Распространение информации об уязвимостях продуктов ОАО «ИнфоТеКС» регулируется политикой ответственного разглашения. Если вы обнаружили уязвимости в продуктах компании, сообщите о них по адресу security-notifications@infotecs.ru.


Общие сведения

В этом разделе:

Состав ПО ViPNet Administrator

Схемы размещения компонентов ПО ViPNet Administrator

Использование ViPNet Client для отправки данных на сетевые узлы

Лицензия на сеть ViPNet


Состав ПО ViPNet Administrator

Программное обеспечение ViPNet Administrator состоит из двух основных компонентов:

  • ViPNet Центр управления сетью (далее ЦУС).
  • ViPNet Удостоверяющий и ключевой центр (далее УКЦ).

Программа ViPNet Центр управления сетью предназначена для формирования структуры сети ViPNet, задания основных параметров сетевых узлов и пользователей, централизованной отправки обновлений ключей, справочников и программного обеспечения на сетевые узлы ViPNet.

Программа ViPNet Центр управления сетью включает два компонента:

  • Серверное приложение, с помощью которого осуществляется работа с с базой данных, содержащей полную информацию о структуре и объектах сети ViPNet, их свойствах и настройках.
  • Клиентское приложение, которое представляет собой удобный графический интерфейс для управления структурой сети ViPNet и свойствами сетевых объектов.

    Возможно удаленное подключение клиентского приложения к серверному приложению, а также одновременное подключение нескольких клиентских приложений к серверному.

Программа ViPNet Удостоверяющий и ключевой центр предназначена для управления ключевой структурой сети ViPNet, а также для издания и обслуживания сертификатов ключа проверки электронной подписи, которые хранятся в базе данных. В соответствии с основными функциями УКЦ условно можно разделить на два компонента: ключевой центр и удостоверяющий центр.

Взаимодействие ЦУСа и УКЦ осуществляется посредством базы данных SQL. Программы независимо друг от друга обращаются к SQL-базе, в которой хранится необходимая информация. Изменения, выполненные в одной программе, незамедлительно отображаются в другой.


Схемы размещения компонентов ПО ViPNet Administrator

Перед установкой ПО ViPNet Administrator выберите компьютеры, на которых будут размещены следующие компоненты:

  • База данных ViPNet Administrator.
  • Серверное приложение ViPNet Центр управления сетью.
  • Программа ViPNet Удостоверяющий и ключевой центр.
  • Одно или несколько клиентских приложений ViPNet Центр управления сетью.

Указанные компоненты можно установить на один или несколько компьютеров сети в любой комбинации. Принципиальное различие между вариантами размещения заключается во взаимном расположении компонентов и базы данных ViPNet Administrator. Поэтому можно выделить две базовые схемы размещения компонентов ПО ViPNet Administrator:

  1. Установка компонентов ViPNet Administrator на одном компьютере.
  2. Установка компонентов ViPNet Administrator на разных компьютерах.

При использовании каждой схемы размещения вы можете установить одно или несколько клиентских приложений ЦУСа на любые компьютеры сети. Возможна установка серверного и клиентского приложений ЦУСа как на один компьютер, так и на разные. В случае установки на разные компьютеры клиентское приложение будет удаленно подключаться к серверному приложению. Также возможно одновременное подключение нескольких клиентских приложений к серверному. Подробную информацию о способах установки клиентского и серверного приложений ЦУСа см. в разделе Размещение клиентского приложения ViPNet Центр управления сетью.

В этом разделе:

Установка компонентов ViPNet Administrator на одном компьютере

Установка компонентов ViPNet Administrator на разных компьютерах

Размещение клиентского приложения ViPNet Центр управления сетью


Установка компонентов ViPNet Administrator на одном компьютере

Эта схема является наиболее простой и подходит для небольших сетей с одним администратором, работающим и с ЦУСом, и с УКЦ. Она предполагает размещение ЦУСа, УКЦ и SQL-сервера с базой данных ViPNet Administrator на одном компьютере, поэтому исключаются дополнительные трудности c развертыванием SQL-сервера.


Установка компонентов ViPNet Administrator на разных компьютерах

Этой схемой развертывания вы можете воспользоваться в том случае, если в вашей организации уже развернут SQL-сервер и планируется, что база данных ViPNet Administrator будет размещаться на нем. В этом случае все остальные компоненты ViPNet Administrator также размещаются на отдельных компьютерах (что удобно в том случае, если управлением сети занимаются несколько администраторов).


Размещение клиентского приложения ViPNet Центр управления сетью

В рассмотренных основных схемах размещения компонентов ПО клиентское приложение ЦУСа может быть установлено на любом компьютере сети ViPNet. Существуют следующие возможности установки приложений:

  • Серверное и клиентское приложения ЦУСа могут быть установлены как на один, так и на разные компьютеры.
  • Клиентское приложение ЦУСа может быть установлено как на один, так и на несколько компьютеров.

Установка серверного и клиентского приложений ЦУСа на разные компьютеры дает возможность использовать отдельный мощный компьютер для размещения серверного приложения. Установка клиентских приложений на несколько компьютеров дает возможность администрирования в многопользовательском режиме. Вы можете выбрать расположение клиентского приложения ЦУСа, учитывая потребности вашей организации и необходимое количество администраторов сети.


Использование ViPNet Client для отправки данных на сетевые узлы

Для функционирования сети ViPNet необходимо организовать передачу с рабочего места администратора на сетевые узлы ключей, справочников, сертификатов и обновлений программного обеспечения. Эти задачи может выполнить транспортный модуль ViPNet MFTP, входящий в состав ПО ViPNet Client.

ПО ViPNet Сlient необходимо установить на компьютер с серверным приложением ViPNet Центр управления сетью. Также, для упрощения организации соединения, ViPNet Client необходимо установить на компьютеры с клиентским приложением ЦУСа и с УКЦ. Для совместной работы с ПО ViPNet Administrator 4.x следует использовать ПО ViPNet Client версии 4.2 и выше.

Примечание. Установка ПО ViPNet Client на отдельный не подключенный к сети компьютер с УКЦ необязательна, однако в этом случае на компьютере с серверным приложением ЦУСа в программе ViPNet Монитор (входящей в состав ПО ViPNet Client) необходимо создать сетевой фильтр для соединения с сетевым узлом УКЦ.

Использование ViPNet Client на компьютере с серверным приложением ЦУСа позволяет:

  • Организовать защиту (шифрование) IP-трафика между рабочим местом администратора и другими узлами сети (см. схему ниже).
  • Обеспечить защиту рабочего места администратора от несанкционированного доступа при работе в локальных и глобальных сетях с помощью встроенного межсетевого экрана.


Лицензия на сеть ViPNet

Для того чтобы развернуть сеть ViPNet, необходима соответствующая лицензия, которую можно приобрести в ОАО «ИнфоТеКС».

Лицензия на сеть ViPNet находится в специальном файле *.itcslic или infotecs.reg, без этого файла работа программного обеспечения ViPNet Administrator будет невозможна.

Файл лицензии содержит следующую информацию:

  • Номер сети ViPNet и номера подчиненных сетей — в том случае, если лицензия предполагает создание иерархии сетей ViPNet.
  • Сведения о владельце сети.
  • Возможность использования функций удостоверяющего центра и максимальное число сертификатов ключа проверки электронной подписи, которое может быть издано в УКЦ для внешних пользователей и пользователей ViPNet.
  • Список ролей, разрешенных для использования в сети ViPNet и ограничения на количество узлов с различными ролями.
  • Ограничения на версии и период использования программного обеспечения для ролей.
  • Общий срок действия лицензии.

Лицензии могут быть двух типов:

  • С поддержкой иерархии сетей ViPNet.
  • Без поддержки иерархии сетей ViPNet.

Если вы обладаете лицензией с поддержкой иерархии сетей ViPNet, вы можете создать помимо главной одну или несколько подчиненных сетей. Для получения более подробной информации см. документ «ViPNet Центр управления сетью. Руководство администратора».

При увеличении числа клиентов сети может потребоваться расширение лицензии. Для этого обратитесь к представителю ОАО «ИнфоТеКС» и закажите новую лицензию, дополнительно сообщив номер сети ViPNet и желаемые параметры новой лицензии. Чтобы узнать номер сети, в клиентском приложении ЦУСа или в УКЦ в меню Справка выберите пункт О программе.

После обработки запроса на расширение лицензии вы получите новый файл *.itcslic или infotecs.reg. В окне клиентского приложения ViPNet Центр управления сетью в меню Лицензия выберите пункт Обновить лицензию и укажите местоположение обновленного файла лицензии, затем перезапустите программу. После перезапуска программы будет использоваться расширенная лицензия.


Установка программного обеспечения ViPNet Administrator

В этом разделе:

Порядок установки компонентов ПО ViPNet Administrator

Информация для администратора SQL

Установка серверного приложения ViPNet Центр управления сетью

Установка клиентского приложения ViPNet Центр управления сетью

Установка программы ViPNet Удостоверяющий и ключевой центр

Установка обновлений для стороннего ПО


Порядок установки компонентов ПО ViPNet Administrator

Для успешного развертывания ПО ViPNet Administrator требуется выполнить все действия из приведенного ниже списка.

Внимание! Программы ViPNet Центр управления сетью и ViPNet Удостоверяющий и ключевой центр разных версий могут быть несовместимы друг с другом.

Порядок установки компонентов ПО ViPNet Administrator

Действие

Ссылка

Продумайте схему размещения компонентов ПО ViPNet Administrator.

Схемы размещения компонентов ПО ViPNet Administrator

Определите количество компьютеров, на которых будет установлено клиентское приложение ЦУСа.

Размещение клиентского приложения ViPNet Центр управления сетью

Подготовьте нужное количество компьютеров и организуйте их подключение к физической сети.

Убедитесь, что располагаете файлом лицензии на сеть ViPNet *.itcslic или infotecs.reg.

Лицензия на сеть ViPNet

Разверните SQL-сервер на выделенном компьютере, если требуется, чтобы база данных размещалась отдельно от компонентов ViPNet Administrator.

См. эксплуатационную документацию на SQL-сервер.

Выполните установку серверного приложения ЦУСа с учетом выбранного варианта установки приложений ЦУСа.

Если база данных ViPNet Administrator размещена на отдельном компьютере, в процессе установки серверного приложения подключитесь к ней.

Установка серверного приложения ViPNet Центр управления сетью

Выполните установку клиентского приложения ЦУСа с учетом выбранного варианта установки приложений ЦУСа.

Установка клиентского приложения ViPNet Центр управления сетью

Установите обновления безопасности для используемого ПО сторонних производителей

Установка обновлений для стороннего ПО

Выполните установку УКЦ с учетом выбранной схемы размещения компонентов ПО ViPNet Administrator.

Установка программы ViPNet Удостоверяющий и ключевой центр

Установите ПО ViPNet Client версии 4.2 и выше на компьютеры с серверным и клиентским приложениями ЦУСа, а также на компьютер с УКЦ.

См. раздел «Установка ПО ViPNet Client» в документе «ViPNet Client Монитор. Руководство пользователя».

Выполните первый запуск клиентского приложения ЦУСа и создайте структуру сети ViPNet.

Первый запуск программы ViPNet Центр управления сетью

Выполните первый запуск и первичную инициализацию УКЦ.

Первый запуск программы ViPNet Удостоверяющий и ключевой центр

Первичная инициализация программы ViPNet Удостоверяющий и ключевой центр

Совет. Мы рекомендуем распечатать список и отмечать в нем шаги по мере их выполнения.


Информация для администратора SQL

В программном обеспечении ViPNet Administrator серверное приложение ViPNet Центр управления сетью и программа ViPNet Удостоверяющий и ключевой центр обмениваются данными друг с другом через базу данных SQL-сервера, в которой хранится информация о структуре и настройках сети ViPNet. В процессе работы с помощью программы ViPNet Удостоверяющий и ключевой центр вы можете создавать резервные копии этой базы данных, чтобы при необходимости вернуться к той или иной конфигурации сети (подробнее см. в документе «ViPNet Удостоверяющий и ключевой центр. Руководство администратора», в разделе «Административные функции»).

База данных создается автоматически при установке серверного приложения ЦУСа. Для размещения базы данных можно использовать существующий именованный экземпляр SQL-сервера (instance), который установлен на локальный или удаленный компьютер. Поддерживаемые версии SQL-сервера приведены в разделе Серверное приложение.

Если подходящего SQL-сервера нет, можно установить SQL-сервер, входящий в комплект поставки ViPNet Administrator. В этом случае при установке серверного приложения ЦУСа автоматически устанавливается английская версия программы Microsoft SQL Server 2014 Express и создается именованный экземпляр SQL-сервера с названием по умолчанию WINNCCSQL. Название можно изменить в процессе установки серверного приложения ЦУСа.

Примечание. Установка именованного экземпляра на компьютер, на котором ранее уже был установлен другой экземпляр, никак не повлияет на его работу. Два экземпляра будут работать параллельно.

При установке серверного приложения ЦУСа на SQL-сервере создаются:

  • База данных с именем ViPNetAdministrator.
  • База данных с именем ViPNetJournals, в которой хранятся журналы аудита программы ViPNet Центр управления сетью.
  • Учетная запись пользователя с правами администратора базы данных для пользователя, от имени которого был запущен файл установки серверного приложения ЦУСа.
  • Две учетные записи пользователей KcaUser и NccUser, под которыми осуществляется подключение УКЦ и серверного приложения ЦУСа к базе данных соответственно. Серверное приложение ЦУСа подключается к базе данных при его первом запуске. Подробное описание подключения УКЦ к базе данных см. в разделе Первичная инициализация программы ViPNet Удостоверяющий и ключевой центр.

Параметры созданной базы данных приведены в таблице ниже.

Параметры базы данных

Параметр | Значение параметра
Параметры сортировки (collation) | Cyrillic_General_CI_AS
Модель восстановления (recovery model) | Full

Внимание! Не рекомендуется изменять настройки базы данных и осуществлять какие-либо действия по управлению структурой и информацией непосредственно в базе данных ViPNet Administrator. Подобные действия могут привести к серьезным неполадкам в работе программного продукта ViPNet Administrator. ОАО «ИнфоТеКС» не несет ответственности за ошибки, возникшие вследствие подобных действий.

Именованный экземпляр SQL-сервера должен иметь параметры, приведенные в таблице ниже. При установке SQL-сервера из комплекта поставки ViPNet Administrator эти параметры автоматически устанавливаются в требуемые значения.

Параметры SQL-сервера

Параметр | Значение
FILESTREAM | Разрешить FILESTREAM при доступе через Transact-SQL (Enable FILESTREAM for Transact-SQL access)
 | Разрешить FILESTREAM при потоковом доступе файлового ввода-вывода (Enable FILESTREAM for file I/O streaming access)
 | Разрешить удаленным клиентам потоковый доступ к данным FILESTREAM (Allow remote clients to have streaming access to FILESTREAM data)
Протокол Shared Memory | Включено (Enabled)
Протокол Named pipes | Включено (Enabled)
Протокол TCP/IP | Включено (Enabled)
Состояние службы SQL Server Browser | Работает (Running)
Тип запуска службы SQL Server Browser | Автоматически (Automatic)


Установка серверного приложения ViPNet Центр управления сетью

После выбора схемы размещения компонентов ПО ViPNet Administrator можно приступать к установке серверного приложения ЦУСа.

Прежде чем начать установку программы, убедитесь, что располагаете установочным файлом серверного приложения ViPNet Центр управления сетью.

Для установки приложения выполните следующие действия:

  1. Из папки установочного комплекта серверного приложения ViPNet Центр управления сетью двойным щелчком запустите установочный файл [image].
  2. В окне Установка ViPNet Administrator [Центр управления сетью] будет предложено установить необходимое программное обеспечение. Список необходимого ПО зависит от ранее установленных на компьютер программ. Чтобы начать установку, нажмите кнопку Продолжить.

    Примечание. Установка необходимого программного обеспечения может занять продолжительное время.

  3. Если после установки требуется перезагрузка компьютера, программа выдаст соответствующее сообщение. Выполните перезагрузку. После перезагрузки установка серверного приложения ЦУСа будет продолжена автоматически.
  4. В появившемся окне выберите язык для программы ViPNet Центр управления сетью и нажмите Продолжить.

    Примечание. В данном случае выбирается язык для программы установки ViPNet Центр управления сетью, а также для интерфейса серверного и клиентского приложений ЦУСа.

  5. На странице Лицензионное соглашение ознакомьтесь с условиями лицензионного соглашения. В случае согласия установите соответствующий флажок. Затем нажмите кнопку Продолжить.
  6. На странице Установка продукта задайте параметры подключения к базе данных. Если вы не укажете имя существующего SQL-сервера, на компьютере будет установлен SQL-сервер из комплекта поставки и создан именованный экземпляр с именем WINNCCSQL. При необходимости вы можете задать другое имя экземпляра.

    Чтобы использовать существующий именованный экземпляр SQL-сервера, выполните следующие действия:

    • В поле Имя сервера вместо WINNCCSQL укажите название существующего именованного экземпляра SQL-сервера. Если SQL-сервер находится на удаленном компьютере, вместо точки укажите IP-адрес или DNS-имя удаленного компьютера.
    • В поле Проверка подлинности выберите режим аутентификации при подключении к SQL-серверу. Если SQL-сервер размещен на этом же компьютере, рекомендуется выбрать режим Проверка подлинности Windows. В этом случае аутентификация будет осуществляться операционной системой с использованием учетной записи пользователя Windows. При удаленном размещении SQL-сервера режим аутентификации зависит от политики безопасности, принятой на этом сервере. Если аутентификация осуществляется по учетным данным пользователя SQL-сервера, выберите режим Проверка подлинности SQL Server и укажите имя и пароль учетной записи пользователя SQL-сервера. Чтобы узнать режим аутентификации на удаленном SQL-сервере и учетные данные, обратитесь к администратору SQL-сервера.
    • Для проверки соединения с SQL-сервером нажмите кнопку Проверить подключение. Если вы указали размещение SQL-сервера и при этом SQL-сервер с указанным именем не существует или недоступен, появится сообщение о невозможности подключения к базе данных с указанными параметрами. Нажмите кнопку Закрыть, проверьте правильность выбранного имени сервера и повторите проверку.
  7. Если вы хотите настроить параметры установки, нажмите кнопку Настроить и укажите:
    • Путь к папке установки программы на компьютере.

      Папка установки программы по умолчанию:

      C:\Program Files\InfoTeCS\ViPNet Administrator — для 32-разрядных OC;
      C:\Program Files (x86)\InfoTeCS\ViPNet Administrator — для 64-разрядных OC.

      Внимание! Компоненты ПО ViPNet Administrator являются 32-разрядными приложениями. Рекомендуется использовать папку установки по умолчанию, предложенную инсталлятором.

    • Имя пользователя и название организации.
    • Название папки программы и ее расположение в меню Пуск.
  8. Чтобы начать установку, нажмите кнопку Продолжить.

  9. В появившемся окне проверьте выбранные параметры установки. Чтобы начать установку, нажмите кнопку Установить сейчас.
  10. Если база данных ViPNet Administrator должна размещаться на выделенном SQL-сервере, то укажите имя развернутого SQL-сервера. Если вы не укажете имя существующего SQL-сервера, появится сообщение с предложением создать сервер базы данных с заданным именем. Для создания сервера в окне сообщения нажмите кнопку Да.
  11. После создания сервера базы данных требуется перезагрузка компьютера, программа выдаст соответствующее сообщение. Выполните перезагрузку. После перезагрузки установка серверного приложения ЦУСа будет продолжена автоматически.
  12. В появившемся окне выберите язык для программы ViPNet Центр управления сетью и нажмите Продолжить.
  13. На странице Установка продукта нажмите кнопку Продолжить.
  14. В появившемся окне проверьте выбранные параметры установки. Чтобы начать установку, нажмите кнопку Установить сейчас.
  15. По завершении установки нажмите кнопку Закрыть.

В результате серверное приложение ЦУСа будет установлено на компьютер. Далее вы можете установить одно или несколько клиентских приложений ЦУСа.


Установка клиентского приложения ViPNet Центр управления сетью

После установки серверного приложения ЦУСа установите одно или несколько клиентских приложений ЦУСа на рабочих местах администраторов создаваемой сети.

Прежде чем начать установку программы убедитесь, что располагаете установочным файлом клиентского приложения ViPNet Центр управления сетью.

Для установки приложения выполните следующие действия:

  1. Из папки установочного комплекта клиентского приложения ViPNet Центр управления сетью двойным щелчком запустите установочный файл [image].
  2. При установке клиентского и серверного приложений на разные компьютеры в окне Установка ViPNet Administrator [Центр управления сетью] будет предложено установить необходимое программное обеспечение. Состав устанавливаемого ПО зависит от имеющихся на компьютере программ.

    Примечание. Программные компоненты, необходимые для работы серверного приложения, включают компоненты, необходимые для работы клиентского приложения. Поэтому при установке клиентского приложения на один компьютер с серверным устанавливать эти компоненты повторно не требуется.

  3. Чтобы начать установку, нажмите кнопку Продолжить.

    Примечание. Установка необходимого программного обеспечения может занять продолжительное время.

  4. Если после установки требуется перезагрузка компьютера, программа выдаст соответствующее сообщение. Выполните перезагрузку. После перезагрузки установка клиентского приложения ЦУСа будет продолжена автоматически.
  5. В появившемся окне выберите язык для программы установки ViPNet Центр управления сетью и нажмите Продолжить.

    Примечание. В данном случае выбирается язык только для программы установки ViPNet Центр управления сетью. Язык интерфейса клиентского приложения совпадает с языком, выбранным для интерфейса серверного приложения ЦУСа.

  6. На странице Лицензионное соглашение ознакомьтесь с условиями лицензионного соглашения. В случае согласия установите соответствующий флажок. Затем нажмите кнопку Продолжить.
  7. Если вы хотите настроить параметры установки, нажмите кнопку Настроить на странице Способ установки и укажите:
    • Путь к папке установки программы на компьютере.

      Папка установки программы по умолчанию:

      C:\Program Files\InfoTeCS\ViPNet Administrator — для 32-разрядных OC;
      C:\Program Files (x86)\InfoTeCS\ViPNet Administrator — для 64-разрядных OC.

    • Имя пользователя и название организации.
    • Название папки программы и ее расположение в меню Пуск.
  8. Чтобы начать установку, нажмите кнопку Установить сейчас.

  9. По завершении установки нажмите кнопку Закрыть.

В результате клиентское приложение ЦУСа будет установлено на компьютер. Установите клиентские приложения ЦУСа на рабочие места всех администраторов вашей сети в соответствии с выбранной схемой размещения компонентов ПО ViPNet Administrator. Далее вы можете установить УКЦ.


Установка программы ViPNet Удостоверяющий и ключевой центр

После установки серверного и клиентского приложений ЦУСа можно приступать к установке УКЦ.

Прежде чем начать установку программы:

  • Убедитесь, что на компьютере выполнены стандартные региональные настройки, а также правильно заданы часовой пояс, дата и время. Иначе возможны проблемы с отображением символов.
  • Убедитесь, что располагаете установочным файлом программы ViPNet Удостоверяющий и ключевой центр.

Примечание. Вся информация о лицензионных ограничениях поступит при подключении к базе данных SQL, созданной при установке серверного приложения ЦУСа.

Для установки программы выполните следующие действия:

  1. Из папки установочного комплекта программы ViPNet Удостоверяющий и ключевой центр двойным щелчком запустите установочный файл [image].
  2. Подождите, пока на компьютер будет автоматически установлено необходимое программное обеспечение, в том числе программа ViPNet CSP.
  3. В окне Установка ViPNet Administrator [Удостоверяющий и ключевой центр] на странице Лицензионное соглашение ознакомьтесь с условиями лицензионного соглашения. В случае согласия установите соответствующий флажок. Затем нажмите кнопку Продолжить.
  4. Если вы хотите настроить параметры установки, на странице Способ установки нажмите кнопку Настроить и укажите:
    • Путь к папке установки программы на компьютере.
    • Имя пользователя и название организации.
    • Название папки программы и ее расположение в меню Пуск.
  5. Чтобы начать установку, нажмите кнопку Установить сейчас.
  6. По окончании установки нажмите кнопку Закрыть.
  7. Если после установки требуется перезагрузка компьютера, программа выдаст соответствующее сообщение. Выполните перезагрузку.

    После этого можно начинать работу с ПО ViPNet Administrator.


Установка обновлений для стороннего ПО

Программное обеспечение сторонних производителей, которое необходимо для работы программы ViPNet Центр управления сетью, может содержать уязвимости. Чтобы избежать влияния возможных уязвимостей на работу программы, необходимо своевременно устанавливать обновления безопасности, выпускаемые производителями стороннего ПО.

После установки серверного и клиентских приложений ViPNet Центр управления сетью выполните следующие действия:

  1. Проверьте наличие обновлений безопасности или новых версий стороннего программного обеспечения:
    • Microsoft .NET Framework версии 4.6.2.
    • Microsoft Visual C++ 2010 Redistributable Package.
    • Используемой версии Microsoft SQL Server.
  2. При наличии обновлений установите их.
  3. В процессе эксплуатации программы ViPNet Центр управления сетью регулярно устанавливайте выпускаемые обновления ПО сторонних производителей.


Начало работы

В этом разделе:

Первый запуск программы ViPNet Центр управления сетью

Первый запуск программы ViPNet Удостоверяющий и ключевой центр


Первый запуск программы ViPNet Центр управления сетью

После установки компонентов ПО ViPNet Administrator убедитесь, что располагаете файлом лицензии на сеть ViPNet *.itcslic или infotecs.reg и запустите программу ViPNet Центр управления сетью. Серверное приложение ЦУСа состоит из служб NccService и NccFilewatcherService, которые автоматически запускаются после загрузки операционной системы. Чтобы запустить клиентское приложение ЦУСа:

  1. Выполните одно из действий:
    • Если вы используете операционную систему Windows 7 или Windows Server 2008 R2, в меню Пуск выберите Все программы > ViPNet > ViPNet Administrator > Центр управления сетью.
    • Если вы используете операционную систему Windows 8 или Windows Server 2012, на начальном экране откройте список приложений и выберите ViPNet > Центр управления сетью.

    Примечание. Во время установки положение программы в меню Пуск или в списке приложений могло быть изменено.

  2. При запуске клиентское приложение автоматически подключается к серверному приложению. По умолчанию подключение выполняется по адресу локального компьютера.

    Если клиентское и серверное приложения установлены на разных компьютерах, появится сообщение об отсутствии соединения с сервером. Такое же сообщение появится в случае, если службы серверного приложения не запущены.

    В этом случае в окне сообщения введите IP-адрес или DNS-имя компьютера, на котором установлено серверное приложение ViPNet Центр управления сетью, и нажмите кнопку Продолжить.

  3. В окне входа в программу ViPNet Центр управления сетью введите учетные данные администратора:
    • Имя пользователя: Administrator.
    • Пароль: Administrator.

    После ввода данных нажмите кнопку Продолжить.

  4. При первом входе в программу ViPNet Центр управления сетью в целях безопасности требуется сменить пароль. В окне Смена пароля введите текущий пароль, затем задайте новый пароль и подтвердите его.

    Пароль должен содержать не менее восьми символов.

    Совет. Рекомендуется задавать сложные пароли, содержащие не менее восьми символов, в состав которых входят буквы в разных регистрах, цифры и специальные символы.

  5. В окне Начало работы с ViPNet Центр управления сетью с помощью кнопки Обзор укажите путь к файлу лицензии на сеть ViPNet *.itcslic или infotecs.reg и нажмите кнопку Продолжить.

  6. В появившемся окне выберите один из возможных сценариев работы в программе:
    • Если сеть ViPNet создается заново, то для автоматического формирования структуры сети и выполнения основных настроек координаторов и клиентов с помощью мастера выберите Сформировать структуру защищенной сети автоматически.
    • Если сеть ViPNet уже развернута и в процессе работы с ЦУСом 4.х будут использоваться данные, созданные в ЦУСе 3.2.х, выполните импорт и конвертацию базы данных ЦУСа 3.2.х. Для этого выберите Загрузить структуру существующей сети. Подробнее о том, как выполнить конвертацию, см. документ «ViPNet Administrator. Руководство по обновлению с версии 3.2.x на версию 4.х», раздел «Конвертация данных Центра управления сетью 3.2.х».
    • Если сеть ViPNet создается заново, то для формирования структуры сети и выполнения основных настроек координаторов и клиентов вручную выберите Настроить структуру защищенной сети самостоятельно.

  7. При создании новой сети, если ваша лицензия на сеть ViPNet предполагает создание иерархии сетей, появится сообщение с предложением распределить лицензионные ограничения между сетями.

    Информацию о распределении лицензии см. в документе «ViPNet Центр управления сетью. Руководство администратора».

  8. Начните работу в программе в соответствии с выбранным сценарием. Для получения более подробной информации см. документ «ViPNet Центр управления сетью. Руководство администратора».
  9. В случае необходимости создайте дополнительные учетные записи для работы в Центре управления сетью.

В этом разделе:

Создание дополнительных учетных записей администраторов ЦУСа


Создание дополнительных учетных записей администраторов ЦУСа

Если в вашей сети будут работать несколько администраторов ЦУСа, после первого запуска клиентского приложения ЦУСа создайте для каждого из них отдельную учетную запись администратора. Это позволит производить журналирование и мониторинг всех действий, выполняемых каждым из них. Все администраторы должны при аутентификации в любом клиентском приложении ЦУСа использовать только свои учетные данные. Для создания учетной записи администратора:

  1. В представлении Администрирование в разделе Учетные записи на панели просмотра нажмите кнопку [image].
  2. В окне Новая учетная запись задайте параметры новой учетной записи и нажмите кнопку Создать.

Администратор, для которого создана учетная запись, сможет использовать ее для входа в ЦУС в любом клиентском приложении.


Первый запуск программы ViPNet Удостоверяющий и ключевой центр

После установки УКЦ выполните первый запуск программы. Для этого:

  1. Выполните одно из действий:
    • Если вы используете операционную систему Windows 7 или Windows Server 2008 R2, в меню Пуск выберите Все программы > ViPNet > ViPNet Administrator > Удостоверяющий и ключевой центр.
    • Если вы используете операционную систему Windows 8 или Windows Server 2012, на начальном экране откройте список приложений и выберите ViPNet > Удостоверяющий и ключевой центр.

    Примечание. Во время установки положение программы в меню Пуск или в списке приложений могло быть изменено.

  2. В окне Начало работы с программой Удостоверяющий и ключевой центр выберите один из возможных сценариев дальнейшей работы в программе:
    • Если сеть ViPNet создается заново и в УКЦ будут формироваться новые данные, установите переключатель в положение Настройка новой базы данных и нажмите кнопку Продолжить. Будет запущен мастер первичной инициализации. Выполните процедуру первичной инициализации программы.

    • Если сеть ViPNet уже развернута и в процессе работы с УКЦ 4.х будут использоваться данные, созданные в УКЦ 3.2.х, выполните импорт и конвертацию базы данных УКЦ 3.2.х. Для этого установите переключатель в положение Импорт базы данных программы Удостоверяющий и ключевой центр версии 3.2.х и нажмите кнопку Продолжить, будет запущена программа конвертации данных. Подробнее о том, как выполнить конвертацию, см. документ «ViPNet Administrator. Руководство по обновлению с версии 3.2.x на версию 4.х», раздел «Конвертация данных Удостоверяющего и ключевого центра 3.2.х».

В этом разделе:

Первичная инициализация программы ViPNet Удостоверяющий и ключевой центр


Первичная инициализация программы ViPNet Удостоверяющий и ключевой центр

Если при первом запуске программы ViPNet Удостоверяющий и ключевой центр в окне Начало работы с программой Удостоверяющий и ключевой центр переключатель был установлен в положение Настройка новой базы данных, будет запущен мастер первичной инициализации.

Чтобы провести первичную инициализацию Удостоверяющего и ключевого центра, выполните следующие действия:

  1. На первой странице мастера инициализации нажмите кнопку Далее.
  2. На странице Подключение к базе данных ViPNet Administrator укажите сетевой адрес экземпляра SQL-сервера и имя базы данных.

    Если УКЦ и SQL-сервер установлены на один компьютер с серверным приложением ЦУСа, адрес экземпляра SQL-сервера — .\winnccsql. Если УКЦ установлен на другой компьютер, вместо точки укажите IP-адрес или DNS-имя компьютера, на котором установлен SQL-сервер, например, 192.168.32.152\winnccsql.

    Примечание. В процессе установки серверного приложения ЦУСа название экземпляра SQL-сервера могло быть изменено. В этом случае вместо WINNCCSQL укажите заданное название.

    Имя базы данных по умолчанию — ViPNetAdministrator.

    Внимание! При первичной инициализации не следует изменять имя базы данных, иначе дальнейший процесс инициализации будет невозможен.

  3. Выберите режим аутентификации при подключении к SQL-серверу и нажмите кнопку Далее.

    По умолчанию выбран режим По имени и паролю пользователя SQL-сервера и указано имя пользователя, под учетной записью которого будет осуществляться подключение к SQL-серверу, и пароль. Данная учетная запись создается при установке серверного приложения ЦУСа. Не рекомендуется менять ее параметры (имя — KcaUser, пароль — Number1).

    После этого нажмите кнопку Далее. Будет установлено соединение с SQL-сервером. Если установить соединение не получится, проверьте правильность всех ранее указанных параметров.

  4. На странице Создание администратора сети ViPNet задайте имя учетной записи администратора УКЦ, под которой вы будете работать в программе.
  5. Если в вашей лицензии доступна функциональность удостоверяющего центра, укажите информацию, необходимую для издания корневого сертификата администратора. В противном случае перейдите к шагу 11.
  6. На первых страницах мастера Сведения о владельце сертификата укажите имя администратора и другие необходимые данные, которые впоследствии будут добавлены в его сертификат, и нажмите кнопку Далее.

  7. На странице Дополнительные сведения о владельце сертификата при необходимости отредактируйте дополнительные сведения о владельце. Для этого в списке выберите соответствующие атрибуты, нажмите кнопку Изменить и внесите необходимую информацию. Затем нажмите кнопку Далее.

  8. На странице Параметры ключа электронной подписи выберите криптопровайдер в соответствии с приведенной ниже таблицей либо другой криптопровайдер, установленный на компьютере. Выбранный криптопровайдер определит алгоритм подписи, по которому будет создаваться ключ электронной подписи и ключ проверки электронной подписи и вычисляться хэш-функция.

    Кроме этого, укажите параметры алгоритма подписи. В соответствии с заданными параметрами будет автоматически определена длина ключа проверки электронной подписи и алгоритм хэширования.

    Характеристика криптопровайдеров и алгоритмов электронной подписи

    Криптопровайдер и соответствующий ему алгоритм электронной подписи

    Параметры алгоритма подписи

    Длина ключа проверки электронной подписи и алгоритм хэширования

    Infotecs Cryptographic Service Provider

    ГОСТ Р 34.10-2001

    См. RFC 4357

    Стандарт электронной подписи, основанный на арифметике эллиптических кривых

    OID «1.2.643.2.2.19»

    ГОСТ Р 34.10 - 2001. Параметры по умолчанию (рекомендуется)

    OID «1.2.643.2.2. 35.1»

    ГОСТ Р 34.10 - 2001 Параметры подписи B

    OID «1.2.643.2.2. 35.2»

    ГОСТ Р 34.10 - 2001. Параметры подписи C

    OID «1.2.643.2.2. 35.3»

    512 бит

    ГОСТ Р 34.11-94

    Infotecs GOST 2012/512 Cryptographic Service Provider

    ГОСТ Р 34.10-2012/512

    Новый стандарт электронной подписи от 2012 года с длиной ключа электронной подписи 256 бит

    OID «1.2.643.7.1.1.1.1»

    ГОСТ Р 34.10 - 2001. Параметры по умолчанию (рекомендуется)

    OID «1.2.643.2.2. 35.1»

    ГОСТ Р 34.10 - 2001 Параметры подписи B

    OID «1.2.643.2.2. 35.2»

    ГОСТ Р 34.10 - 2001. Параметры подписи C

    OID «1.2.643.2.2. 35.3»

    512 бит

    ГОСТ Р 34.11-2012/256

    Infotecs GOST 2012/1024 Cryptographic Service Provider

    ГОСТ Р 34.10-2012/1024

    Новый стандарт электронной подписи от 2012 года с длиной ключа электронной подписи 512 бит

    OID «1.2.643.7.1.1.1.2»

    ГОСТ Р 34.10 - 2012/1024. Набор параметров А

    ГОСТ Р 34.10 - 2012/1024. Набор параметров B

    1024 бит

    ГОСТ Р 34.11-2012/512

    Совет. Рекомендуется использовать параметры алгоритма, предлагаемые по умолчанию. Данные параметры характеризуются наибольшей скоростью вычисления и проверки электронной подписи.

  9. На странице Срок действия сертификата любым удобным способом задайте срок действия сертификата.

  10. Если в УКЦ требуется издавать квалифицированные сертификаты (работа в режиме аккредитованного удостоверяющего центра), на странице Программные средства установите флажок Функционировать в режиме аккредитованного удостоверяющего центра и с помощью кнопки Настроить укажите средства, используемые вашим удостоверяющим центром. Подробную информацию о работе в режиме аккредитованного удостоверяющего центра см. в документе «ViPNet Удостоверяющий и ключевой центр. Руководство администратора», в главе «Управление сертификатами», в разделе «Издание квалифицированных сертификатов».

    При необходимости на данной странице вы также можете дополнительно указать информацию о средстве электронной подписи владельцев сертификатов (пользователей).

    Примечание. Установить флажок и указать все необходимые сведения об используемых средствах можно и после проведения первичной инициализации в настройках программы, но в данном случае стоит учесть, что ранее изданный для вас сертификат ключа проверки электронной подписи не будет соответствовать формату квалифицированного сертификата.

  11. На странице Автоматический режим работы выполните одно из действий:
    • Измените время неактивности администратора, по истечении которого будет осуществляться переход УКЦ в автоматический режим работы (по умолчанию — 15 минут).
    • Чтобы в случае, когда администратор не совершает никаких действий, переход УКЦ в автоматический режим работы не производился, снимите соответствующий флажок.

    Подробную информацию о работе УКЦ в автоматическом режиме см. в документе «ViPNet Удостоверяющий и ключевой центр. Руководство администратора», в разделе «Режимы работы в программе ViPNet Удостоверяющий и ключевой центр».

    Примечание. Настроить параметры автоматического режима работы УКЦ можно и после проведения первичной инициализации в настройках программы.

  12. Если на предыдущем шаге вы выбрали переход УКЦ в автоматический режим работы в случае неактивности администратора, настройте операции, которые должны выполняться в автоматическом режиме работы УКЦ. Для этого выберите операцию, нажмите кнопку Настроить и в появившемся окне установите соответствующий флажок. Для операций создания ключей узлов, загрузки списков аннулированных сертификатов доверенных сетей ViPNet или обновления списков аннулированных сертификатов укажите, когда эта операция должна выполняться.

    Примечание. Если у вас отсутствует лицензия на работу УКЦ в роли удостоверяющего центра (подробнее см. в документе «ViPNet Удостоверяющий и ключевой центр. Руководство администратора», в главе «Общие сведения»), для выполнения в автоматическом режиме работы программы вы можете выбрать только создание ключей узлов и удовлетворение запросов на дистрибутивы ключей.
  13. На странице Место хранения контейнеров ключа электронной подписи и ключа защиты УКЦ выберите место хранения контейнера ключей администратора: В файле или На внешнем устройстве. Если выбрано хранение контейнера ключа на внешнем устройстве, то далее выберите внешнее устройство хранения данных, предварительно подключив его и установив для него драйвер. При необходимости введите ПИН-код внешнего устройства.

    В зависимости от выбранного места хранения будет определен срок действия ключа электронной подписи. При хранении ключа электронной подписи в файле на компьютере либо на внешнем устройстве, которое не поддерживает алгоритм ГОСТ 34.10-2001, срок действия ключа ограничивается одним годом. Если ключ электронной подписи хранится на устройстве с поддержкой ГОСТ 34.10-2001 (был непосредственно сформирован на нем), то его срок действия составляет 3 года.

    По истечении срока действия должна быть произведена плановая смена ключа электронной подписи. При этом под сроком действия понимается срок использования ключа электронной подписи для подписи издаваемых сертификатов пользователей. На электронную подпись списка аннулированных сертификатов срок действия ключа электронной подписи не распространяется. По истечении срока действия ключа электронной подписи список аннулированных сертификатов может быть им подписан.

    Место хранения ключа электронной подписи и срок его действия должны быть зафиксированы в регламенте работы удостоверяющего центра.

  14. На странице Настройка паролей укажите следующие параметры:
    • Тип создаваемых паролей:
      • Собственный пароль — пароль, определяемый администратором.
      • Случайный пароль на основе парольной фразы — пароль, формируемый автоматически на основе парольной фразы.

      Примечание. Указанный тип паролей будет сохранен в настройках программы и будет учитываться при создании других паролей. Если вы хотите, чтобы остальные пароли создавались другого типа, измените соответствующие настройки.

    • Способ выдачи паролей пользователям ViPNet:
      • Сохранять пароль в файл XPS в папку — для выдачи паролей в файлах. Укажите папку, в которой будут сохраняться файлы с паролями.
      • Печатать пароль на принтере — для выдачи паролей в распечатанном виде. В списке принтеров выберите принтер, который будет использоваться для печати.

  15. Если на предыдущем шаге выбран тип Собственный пароль, то на появившейся странице задайте пароль администратора и его подтверждение. Пароль должен содержать не менее 8 символов.

    Внимание! Рекомендуется задавать сложные пароли, содержащие не менее восьми символов, в состав которых входят буквы в разных регистрах, цифры и специальные символы.

    Не создавайте пароль длиной в 32 символа. В дальнейшем произвести аутентификацию по паролю с такой длиной будет невозможно. Данное ограничение связано с существующим алгоритмом передачи пароля в криптопровайдер. В соответствии с этим алгоритмом длина пароля не должна превышать 31 символ.

    Если был выбран тип одного из случайных паролей, то при появлении электронной рулетки поводите указателем в пределах окна и на появившейся странице запомните новый пароль (или парольную фразу).

    При необходимости измените параметры случайного пароля и создайте другой.

  16. На странице готовности к завершению первичной инициализации УКЦ убедитесь в правильности параметров, заданных на предыдущих страницах мастера. Чтобы отправить эти параметры на печать, нажмите кнопку Печать. При необходимости изменения параметров вернитесь на нужную страницу с помощью кнопки Назад.

    Для продолжения работы нажмите кнопку Далее. Появится электронная рулетка, если она еще не запускалась в процессе первичной инициализации. Поводите указателем в пределах окна Электронная рулетка.

  17. При успешном завершении инициализации на последней странице мастера появится соответствующее сообщение и напротив каждой выполненной операций отобразится значок [image]. Если при инициализации какие-то операции выполнены с ошибками, они будут отмечены значком [image].

    Убедитесь, что первичная инициализация успешно завершена, после чего нажмите кнопку Закрыть.

При успешном проведении первичной инициализации будут выполнены следующие операции:

  • Создана учетная запись администратора УКЦ.
  • Создан ключ электронной подписи и издан сертификат администратора УКЦ (при наличии разрешения использования функциональности удостоверяющего центра).

    Примечание. Сертификат, изданный для нового администратора, будет самоподписанным. Если УКЦ выступает в роли подчиненного удостоверяющего центра и в соответствии с регламентом такой сертификат нельзя использовать для электронной подписи издаваемых сертификатов пользователей, получите другой сертификат в вышестоящем удостоверяющем центре по специальному запросу (см. документ «ViPNet Удостоверяющий и ключевой центр. Руководство администратора», раздел «Установление доверительных отношений на основе иерархической модели»).

    Кроме этого, если вы задали параметры работы УКЦ как аккредитованного удостоверяющего центра, то изданный сертификат будет соответствовать формату квалифицированного сертификата.

  • Созданы мастер-ключи.
  • Установлено соединение с базой данных SQL и произведено ее заполнение данными.

В случае корректной инициализации появится главное окно программы. Можно приступать к работе с УКЦ.

Если инициализация была проведена некорректно, установите причину неудачи, переустановите УКЦ с предварительным удалением текущей версии программы и повторно проведите первичную инициализацию.


Обновление программного обеспечения ViPNet Administrator

Внимание! Если вы реплицируете таблицы базы данных ПО ViPNet Administrator, производитель не гарантирует работоспособность ПО ViPNet Administrator и при обновлении ПО могут возникнуть ошибки при работе с базой данных. Чтобы обновить ПО ViPNet Administrator, отключите репликацию баз данных.

В этом разделе:

Порядок обновления компонентов ПО ViPNet Administrator

Обновление приложений ViPNet Центр управления сетью

Обновление программы ViPNet Удостоверяющий и ключевой центр


Порядок обновления компонентов ПО ViPNet Administrator

Внимание! После получения обновлений для компонентов ViPNet Administrator обязательно обновите как приложения ViPNet Центр управления сетью, так и программу ViPNet Удостоверяющий и ключевой центр. Программы ViPNet Центр управления сетью и ViPNet Удостоверяющий и ключевой центр разных версий могут быть несовместимы друг с другом.

Обновление компонентов программного обеспечения ViPNet Administrator рекомендуется выполнять в следующем порядке:

  1. Обновите серверное приложение ViPNet Центр управления сетью.
  2. Обновите клиентское приложение ViPNet Центр управления сетью.
  3. Обновите программу ViPNet Удостоверяющий и ключевой центр.

Прежде чем начать обновление компонентов ViPNet Administrator, убедитесь, что ваша лицензия разрешает использование новой версии. Для этого в программе ViPNet Центр управления сетью в меню Лицензия выберите пункт Сведения о лицензии для своей сети. В появившемся окне на вкладке Общие сведения указаны сведения о максимальной версии ViPNet Administrator.

Кроме того, перед обновлением рекомендуется создать с помощью программы ViPNet Удостоверяющий и ключевой центр резервную копию конфигурации сети, которая позволит восстановить данные в случае возникновения проблем после обновления. Подробнее создание и восстановлении резервных копий описано в документе «ViPNet Удостоверяющий и ключевой центр. Руководство администратора», в разделе «Административные функции».


Обновление приложений ViPNet Центр управления сетью

Обновление серверного и клиентского приложений ЦУСа различается тем, что при обновлении серверного приложения необходимо указать параметры подключения к базе данных. Это связано с тем, что вместе с серверным приложением обновляется база данных, в которой хранятся данные о конфигурации сети ViPNet и настройках программ ViPNet Центр управления сетью и ViPNet Удостоверяющий и ключевой центр.

Внимание! Перед обновлением серверного приложения ЦУСа необходимо завершить работу УКЦ.

Чтобы обновить одно из приложений, выполните следующие действия:

  1. Двойным щелчком запустите файл [image] из установочного комплекта новой версии приложения.
  2. В появившемся окне выберите язык для программы ViPNet Центр управления сетью и нажмите Продолжить.
  3. На странице Изменение установленных компонентов выберите Обновить и нажмите кнопку Продолжить.

  4. На странице Обновление продукта задайте параметры подключения к базе данных. Эта страница появляется только при обновлении серверного приложения.

    Для проверки соединения с SQL-сервером нажмите кнопку Проверить подключение. Если проверка подключения выполнена успешно, для продолжения нажмите кнопку Обновить. В противном случае задайте правильные параметры подключения к базе данных.

  5. Дождитесь окончания процесса обновления.

После обновления серверного и клиентских приложений обновите УКЦ.


Обновление программы ViPNet Удостоверяющий и ключевой центр

Для обновления программы ViPNet Удостоверяющий и ключевой центр:

  1. На компьютере с программой ViPNet Удостоверяющий и ключевой центр двойным щелчком запустите файл [image] из установочного комплекта новой версии программы.
  2. На странице Обновление мастера установки ViPNet Удостоверяющий и ключевой центр нажмите кнопку Начать обновление.

  3. Дождитесь завершения процесса обновления и нажмите кнопку Закрыть.
  4. По окончании установки может появиться окно с предложением перезагрузить компьютер. В этом случае перезагрузите компьютер.

Теперь можно приступать к администрированию сети, используя обновленную программу.


Удаление программного обеспечения ViPNet Administrator

В этом разделе:

Когда требуется удаление компонентов ПО ViPNet Administrator

Удаление приложений ViPNet Центр управления сетью

Удаление программы ViPNet Удостоверяющий и ключевой центр


Когда требуется удаление компонентов ПО ViPNet Administrator

Удаление компонентов программного обеспечения ViPNet Administrator требуется после успешной миграции программного обеспечения на новый компьютер (подробнее см. «ViPNet Administrator. Руководство по миграции программного обеспечения на другой компьютер»). При необходимости сценарием удаления вы также можете воспользоваться при некорректном обновлении компонентов программного обеспечения.

В первом случае вместе с компонентами программного обеспечения в обязательном порядке должна быть удалена база данных ViPNet Administrator и все пользовательские данные. Во втором случае удаление базы данных и пользовательских данных определяется на усмотрение администратора.

Базу данных ViPNet Administrator вы можете удалить в процессе удаления серверного приложения ЦУСа, в том случае если установите соответствующий флажок. Удаление пользовательских данных вы можете произвести при удалении каждого компонента ViPNet Administrator также при наличии соответствующих флажков (см. сценарии удаления ниже).


Удаление приложений ViPNet Центр управления сетью

В текущей версии программы удаление серверного и клиентского приложений ViPNet Центр управления сетью возможно только средствами операционной системы.

Чтобы удалить одно из приложений ЦУСа, выполните следующие действия:

  1. В меню Пуск выберите пункт Панель управления.
  2. На странице Настройка параметров компьютера выберите категорию Программы и компоненты.
  3. На странице Удаление или изменение программы выберите в списке нужное приложение и нажмите кнопку Удалить.
  4. В появившемся окне на странице Изменение установленных компонентов выберите Удалить все компоненты и нажмите кнопку Продолжить.
  5. На странице Удаление продукта для удаления пользовательских данных установите соответствующий флажок. Если при удалении серверного приложения установлен данный флажок, то вместе с пользовательскими данными будет удалена база данных ViPNet Administrator. В случае необходимости вы можете проверить связь с базой данных перед ее удалением.
  6. Нажмите кнопку Удалить.
  7. Дождитесь завершения процесса удаления приложения и нажмите кнопку Закрыть.


Удаление программы ViPNet Удостоверяющий и ключевой центр

Для удаления программы ViPNet Удостоверяющий и ключевой центр:

  1. Выполните одно из действий:
    • Если вы используете операционную систему Windows 7 или Windows Server 2008 R2, в меню Пуск выберите Все программы > ViPNet > ViPNet Administrator > Установка ViPNet Удостоверяющий и ключевой центр.
    • Если вы используете операционную систему Windows 8 или Windows Server 2012, на начальном экране откройте список приложений и выберите ViPNet > Установка ViPNet Удостоверяющий и ключевой центр.

    Примечание. Во время установки положение программы в меню Пуск или в списке приложений могло быть изменено.

  2. На странице Изменение установленных компонентов выберите Удалить все компоненты и нажмите кнопку Продолжить.
  3. На странице Удаление продукта установите флажок Удалить пользовательские данные, если вместе с программой вы хотите удалить файлы ключей администратора УКЦ и другие служебные файлы. Нажмите кнопку Удалить.
  4. Дождитесь завершения процесса удаления программы и нажмите кнопку Закрыть.


Возможные неполадки и методы их устранения

При установке и обновлении ПО ViPNet Administrator могут возникать следующие неполадки:

  • Не устанавливаются приложения сторонних производителей.
  • Невозможно установить серверное или клиентское приложение ЦУСа.
  • Невозможно запустить клиентское приложение ЦУСа.
  • Некорректная инициализация УКЦ.
  • После обновления невозможно запустить ЦУС или УКЦ.
  • Некорректно отображаются символы в УКЦ.
  • Невозможно запустить УКЦ.
  • Невозможно изменить путь установки по умолчанию для приложения ЦУС.
  • Невозможно обновить базу данных ЦУС.

В этом разделе:

Не устанавливаются приложения сторонних производителей

Невозможно установить серверное или клиентское приложение ЦУСа

Невозможно запустить клиентское приложение ЦУСа

Некорректная инициализация УКЦ

Невозможно обновить компоненты ЦУСа по причине отсутствия прав доступа к экземпляру SQL-сервера

После обновления невозможно запустить ЦУС или УКЦ

Некорректно отображаются символы в УКЦ

Невозможно запустить УКЦ

Невозможно изменить путь установки по умолчанию для приложения ЦУС

Невозможно обновить базу данных ЦУС


Не устанавливаются приложения сторонних производителей

Возможно, на жестком диске компьютера недостаточно свободного места. Освободите необходимое дисковое пространство и повторите попытку установки.


Невозможно установить серверное или клиентское приложение ЦУСа

Возможные причины:

  • Не установлены актуальные обновления для операционной системы.
  • Параметры выбранного экземпляра SQL-сервера не соответствуют указанным в разделе Информация для администратора SQL. Обратитесь к администратору SQL-сервера.
  • Служба серверного приложения ЦУСа NccService не может быть запущена. Обратитесь к администратору SQL-сервера и проверьте параметры выбранного экземпляра SQL-сервера.

    Если служба по-прежнему не может быть запущена, выполните следующее:

    • На компьютер, на котором находится SQL-сервер, установите среду SQL Server Management Studio 2014 или выше, если она отсутствует. Загрузить ее можно на сайте компании Microsoft.

      Внимание! Среда SQL Server Management Studio должна быть установлена на компьютере после создания сервера базы данных, иначе установка серверного приложения ЦУСа будет невозможна.

    • Запустите среду SQL Server Management Studio с помощью меню Пуск.
    • Подключитесь к установленному SQL-серверу.
    • Откройте окно свойств установленного SQL-сервера и выполните следующие настройки:
      • на панели навигации Выбор страницы выберите раздел Дополнительно (Advanced) и на панели просмотра в группе FILESTREAM в списке Уровень доступа FILESTREAM (Filestream Access Level) выберите Включен полный доступ (Full access enabled);
      • на панели навигации Выбор страницы выберите раздел Безопасность (Security) и на панели просмотра в группе Серверная проверка подлинности (Server authentication) установите значение Проверка подлинности SQL Server и Windows (SQL Server and Windows Authentication mode).
  • Компьютер, на который вы пытаетесь установить серверное приложение ЦУСа и систему управления базами данных (СУБД), является контроллером домена. Из соображений безопасности компания Microsoft не рекомендует устанавливать SQL-сервер на контроллер домена. Установите СУБД на компьютер, не являющийся контроллером домена.
  • Возникли ошибки установки дополнительного ПО сторонних производителей, не связанные с ПО ViPNet Administrator. Чтобы исключить ошибки установки дополнительного ПО, обновите или установите вручную следующее дополнительное ПО из папки установочного комплекта ПО ViPNet Центр управления сетью:
    • Microsoft .NET Framework версии 4.6.2 (программная платформа).
    • Microsoft Visual C++ 2010 Redistributable Package (набор компонентов среды выполнения библиотек Visual C++).
    • Microsoft SQL Server 2014 Express. При установке должны быть указаны параметры SQL-сервера, как описано в разделе Информация для администратора SQL.

    При запуске установщика дополнительного ПО могут появиться сообщения об ошибках. Необходимо следовать рекомендациям, которые приведены в сообщениях. При необходимости обратитесь за дополнительными сведениями по устранению неполадок к документации на сайте компании Microsoft.


Невозможно запустить клиентское приложение ЦУСа

Возможные причины:

  • Службы серверного приложения ЦУСа NccService и NccFilewatcherService не запустились автоматически после загрузки операционной системы. Запустите эти службы, для этого:
    • Запустите «Диспетчер задач Windows» с помощью сочетания клавиш Ctrl+Shift+Esc.
    • В окне Диспетчер задач Windows перейдите на вкладку Службы.
    • В списке найдите службу NccService, щелкните эту службу правой кнопкой мыши и в контекстном меню выберите пункт Запустить службу.
    • Таким же образом запустите службу NccFilewatcherService.
  • Компьютер с серверным приложением ЦУСа выключен.
  • Отсутствует соединение между компьютерами с клиентским и серверным приложениями ЦУСа. Для проверки соединения между компьютерами воспользуйтесь командой ping.
  • На компьютере с клиентским или серверным приложением ЦУСа запущен межсетевой экран, блокирующий соединение (например, брандмауэр Windows). Проверьте настройки межсетевых экранов.
  • Ваш компьютер не подключен к сети.


Некорректная инициализация УКЦ

Возможные причины:

  • Некорректная работа электронной рулетки.
  • Случайное или умышленное повреждение (удаление) базы данных.
  • Заданы неверные учетные данные пользователя базы SQL. По умолчанию для УКЦ заданы следующие учетные данные:
    • Имя пользователя: KcaUser.
    • Пароль: Number1.

После установления причины ошибки повторно проведите первичную инициализацию программы ViPNet Удостоверяющий и ключевой центр. Если при запуске программы мастер первичной инициализации не вызывается автоматически, удалите папку C:\ProgramData\Infotecs\ViPNet Administrator\KC вместе с ее содержимым.


Невозможно обновить компоненты ЦУСа по причине отсутствия прав доступа к экземпляру SQL-сервера

При обновлении компонентов ViPNet Центр управления сетью может появиться следующее сообщение:

Это означает, что вы не можете обновить компоненты ЦУСа по причине отсутствия прав доступа к экземпляру SQL-сервера, на котором развернута база данных ViPNet Administrator. Данная проблема может возникать в том случае, если вы удалили учетную запись администратора в ОС Windows, под которой первоначально разворачивались компоненты ЦУСа и база данных SQL, либо стали использовать доменную учетную запись.

В этом случае для устранения указанной проблемы выполните следующие действия:

  1. Обратитесь в службу технического сопровождения «ИнфоТеКС» для получения утилиты NccRegistrator.exe, с помощью которой вы сможете получить доступ к базе данных ViPNet Administrator под вашей текущей учетной записью.
  2. Скопируйте утилиту на компьютер, на котором установлено серверное приложение ЦУСа.
  3. Запустите исполняемый файл утилиты.
  4. В появившемся окне введите имя и пароль администратора ЦУСа, который вы обычно указываете при запуске клиентского приложения ЦУСа. Если вы при развертывании компонентов ЦУСа изменяли имя SQL-сервера, укажите это имя в поле Имя экземпляра баз данных.

  5. Нажмите кнопку Выполнить.
  6. Если в поле Состояние появилось сообщение «Готово», то вы можете повторить попытку обновления компонентов ЦУСа. Если в этом поле появилось сообщение об ошибке, проверьте правильность введенных данных.


После обновления невозможно запустить ЦУС или УКЦ

Возможно, обновлены не все компоненты ПО ViPNet Administrator. Убедитесь, что обновлены все приложения, входящие в состав ПО ViPNet Administrator: клиентское и серверное приложение ЦУСа, УКЦ.


Некорректно отображаются символы в УКЦ

Возможно, не выполнены стандартные региональные настройки в ОС Windows. Откройте панель управления и выполните необходимые настройки.


Невозможно запустить УКЦ

Возможны следующие причины:

  • Компьютер с серверным приложением ЦУСа и базой SQL выключен.
  • Отсутствует соединение между компьютерами с серверным приложениями ЦУСа и УКЦ. Для проверки соединения между компьютерами воспользуйтесь командой ping.
  • На компьютере с УКЦ или серверным приложением ЦУСа запущен межсетевой экран, блокирующий соединение (например, брандмауэр Windows). Проверьте настройки межсетевых экранов.
  • Ваш компьютер не подключен к сети.


Невозможно изменить путь установки по умолчанию для приложения ЦУС

Приложения ЦУС имеют следующие папки установки по умолчанию:

  • C:\Program Files\InfoTeCS\ViPNet Administrator — для 32-разрядных OC;
  • C:\Program Files (x86)\InfoTeCS\ViPNet Administrator — для 64-разрядных OC.

В случае если была выбрана папка установки, отличная от папки по умолчанию, а приложение установлено в папку по умолчанию, то это могло произойти, если в качестве папки установки была выбрана системная папка ОС, не предназначенная для этого.

Рекомендуется использовать папку установки по умолчанию, предложенную инсталлятором.

Компоненты ПО ViPNet Administrator являются 32-разрядными приложениями. При их установке на 64-разрядных OC не допускается использование системных папок ОС, предназначенных для размещения 64-разрядных приложений (C:\Program Files\), а также не предназначенных для установки сторонних приложений (например, C:\Windows), так как при установке в такую папку указанный путь будет изменён встроенными в ОС средствами контроля на указанный по умолчанию без каких-либо уведомлений.

Внимание! Не допускается установка ПО ViPNet Administrator на сетевой диск или внешний накопитель (USB-флэш или USB-HDD).


Невозможно обновить базу данных ЦУС

Если вы реплицируете таблицы базы данных ПО ViPNet Administrator, производитель не гарантирует работоспособность ПО ViPNet Administrator и при обновлении ПО могут появиться сообщения об ошибках. Чтобы обновить ПО ViPNet Administrator, отключите репликацию базы данных ПО ViPNet Administrator. Таблицы базы данных ПО ViPNet Administrator не рекомендуется модифицировать. База данных ПО ViPNet Administrator не поддерживают репликацию баз данных.


Региональные настройки

Для корректного отображения русской локализации интерфейса программ ViPNet в русифицированных ОС Microsoft Windows английской локализации необходимо установить поддержку кириллицы для программ, не поддерживающих Юникод. Эти настройки рекомендуется производить до установки самой программы.

Данные настройки также понадобится сделать, если установлен русскоязычный MUI (Multilanguage User Interface). Это значит, что ядро операционной системы английское, а русский язык для интерфейса и файлов справки был установлен позже. В этом случае региональные настройки по умолчанию английские и требуют изменения.

Внимание! Для изменения региональных настроек вы должны обладать правами администратора операционной системы.

В этом разделе:

Региональные настройки в ОС Windows 7, Windows Server 2008 R2

Региональные настройки в ОС Windows 8, Windows Server 2012, Windows 8.1, Windows Server 2012 R2, Windows 10


Региональные настройки в ОС Windows 7, Windows Server 2008 R2

Для установки поддержки кириллицы на ОС Windows 7, Windows Server 2008 R2 выполните следующие действия:

  1. Откройте панель управления (Control Panel) и в категории Часы, язык и регион (Clock, Language, and Region) выберите параметр Язык и региональные стандарты (Region and Language).
  2. В окне Язык и региональные стандарты (Region and Language) перейдите на вкладку Дополнительно (Administrative).

  3. На вкладке Дополнительно (Administrative) нажмите кнопку Изменить язык системы (Change system locale).
  4. В появившемся окне в списке Current system locale выберите Русский (Россия) (Russian (Russia)).

  5. Нажмите кнопку OK. Перезагрузите компьютер.
  6. Дождитесь завершения перезагрузки компьютера, откройте панель управления (Control Panel) и в категории Часы, язык и регион (Clock, Language, and Region) выберите параметр Язык и региональные стандарты (Region and Language).
  7. В окне Язык и региональные стандарты (Region and Language) перейдите на вкладку Дополнительно (Administrative).
  8. На вкладке Дополнительно (Administrative) нажмите кнопку Копировать параметры (Copy settings).
  9. В открывшемся окне в списке Копировать текущие параметры в (Copy your current settings to)установите флажок Экран приветствия и системные учетные записи (Welcome screen and system accounts) и нажмите кнопку OK.

Также для исключения проблем с кодировкой в некоторых системах мы рекомендуем выполнить следующие действия:

  1. В окне Язык и региональные стандарты (Region and Language) на вкладке Форматы (Formats) в списке Формат (Format) выберите Русский (Россия) (Russian (Russia)).

  2. В окне Язык и региональные стандарты (Region and Language) на вкладке Расположение (Location) в списке Текущее расположение (Current location) выберите Россия (Russia).


Региональные настройки в ОС Windows 8, Windows Server 2012, Windows 8.1, Windows Server 2012 R2, Windows 10

Для установки поддержки кириллицы на ОС Windows 8, Windows Server 2012, Windows 8.1, Windows Server 2012 R2, Windows 10 выполните следующие действия:

  1. Откройте панель управления (Control Panel) и в категории Часы, язык и регион (Clock, Language, and Region) выберите параметр Изменение форматов даты, времени и чисел (Change date, time, or number formats).
  2. В окне Регион (Region) перейдите на вкладку Дополнительно (Administrative).

  3. На вкладке Дополнительно (Administrative) нажмите кнопку Изменить язык системы (Change system locale).
  4. В появившемся окне в списке выберите Русский (Россия) (Russian (Russia)).

  5. Нажмите кнопку OK. Перезагрузите компьютер.
  6. Дождитесь завершения перезагрузки компьютера, откройте панель управления (Control Panel) и в категории Часы, язык и регион (Clock, Language, and Region) выберите параметр Изменение форматов даты, времени и чисел (Change date, time, or number formats).
  7. В окне Регион (Region) перейдите на вкладку Дополнительно (Administrative).
  8. На вкладке Дополнительно (Administrative) нажмите кнопку Копировать параметры (Copy settings).
  9. В открывшемся окне в списке Копировать текущие параметры в (Copy your current settings to) установите флажок Экран приветствия и системные учетные записи (Welcome screen and system accounts) и нажмите кнопку OK.

Также для исключения проблем с кодировкой в некоторых системах мы рекомендуем выполнить следующие действия:

  1. В окне Регион (Region) на вкладке Форматы (Formats) в списке Формат (Format) выберите Русский (Россия) (Russian (Russia)).

  2. В окне Регион (Region) на вкладке Местоположение (Location) в списке Основное расположение (Home location) выберите Россия (Russia).


Внешние устройства

В этом разделе:

Общие сведения

Список поддерживаемых внешних устройств

Алгоритмы и функции, поддерживаемые внешними устройствами


Общие сведения

Внешние устройства предназначены для хранения контейнеров ключей, которые вы можете использовать для аутентификации, формирования электронной подписи или для других целей.

На внешнем устройстве могут храниться ключи, созданные по различным алгоритмам в программном обеспечении ViPNet или в сторонних программах. Максимальное количество контейнеров ключей, которое может храниться на одном внешнем устройстве, зависит от объема памяти устройства.

Все операции с контейнерами ключей и внешними устройствами вы можете выполнить в программе ViPNet CSP. Чтобы использовать какое-либо внешнее устройство, на компьютер необходимо установить драйверы этого устройства. Перед записью ключей на устройство убедитесь, что оно отформатировано.


Список поддерживаемых внешних устройств

В следующей таблице перечислены внешние устройства, которые могут быть использованы в программном обеспечении ViPNet. Для каждого семейства устройств в таблице приведено описание, указаны условия и особенности работы с устройствами.

Поддерживаемые внешние устройства

Название семейства устройств в программе ViPNet CSP

Полные названия и типы устройств

Необходимые и рекомендуемые условия работы с семейством устройств

ESMART Token

Смарт-карты и токены семейств ESMART Token, ESMART Token ГОСТ, ESMART Token USB 64K

На компьютере должно быть установлено ПО ESMART PKI Client (рекомендуемая версия — 4.2.33).

С помощью ПО ESMART PKI Client для Windows вам может потребоваться отформатировать устройство с профилем ViPNet2.

Перенос ключей подписи с устройства и на устройство ESMART Token ГОСТ невозможен, так как на устройстве используется аппаратная криптография с неизвлекаемым ключом.

При использовании устройства ESMART Token ГОСТ возможна аутентификация только по персональному ключу на устройстве.

Infotecs Software Token

Infotecs Software Token — программная реализация стандарта PKCS#11

Необходимое ПО входит в поставку ViPNet CSP.
С помощью программы token_manager.exe на компьютере должен быть создан виртуальный токен.

Подробную информацию о работе с программным токеном см. в документе «Криптографический интерфейс ViPNet PKCS#11 VT. Руководство разработчика», раздел «Создание и удаление слотов и токенов в ViPNet PKCS#11 VT».

A-Key

Смарт-карты
aKey S1000,
aKey S1003,
aKey S1004
производства компании
Ak Kamal Security

На компьютере должна быть установлена библиотека akpkcs11.dll, предоставленная компанией Ak Kamal Security.

Устройство имеет два ПИН-кода: администратора и пользователя. Значение этих ПИН-кодов по умолчанию — 12345678.

Перенос ключей подписи с устройств и на устройства данного семейства невозможен, так как на устройствах используется аппаратная криптография с неизвлекаемым ключом.

При использовании этих устройств возможна аутентификация только по персональному ключу на устройстве.

ViPNet HSM

Виртуальный токен ViPNet HSM производства ОАО «ИнфоТеКС»

Необходимо установить клиентское приложение ViPNet HSM и проинициализировать виртуальный токен.

JaCarta

Персональные электронные ключи и смарт-карты JaCarta PKI, JaCarta Laser производства компании
«Аладдин Р.Д.»

На компьютере должно быть установлено ПО «Единый Клиент JaCarta» компании «Аладдин Р.Д.» (рекомендуемая версия — 2.9.0.1531).

Устройства JaCarta PKI/ГОСТ определяются как принадлежащие одновременно к семействам JaCarta и eToken GOST/JaCarta GOST. Во избежание возникновения проблем рекомендуется запретить опрос неиспользуемого семейства устройств.

При использовании устройства JaCarta PKI/ГОСТ во избежание появления ошибок не следует сохранять ПИН-коды этого устройства на компьютере.

JCDS

Смарт-карты Gemalto Optelio Contactless D72, KONA 131 72K и токен JaCarta LT с апплетом от компании «Аладдин Р.Д.»

На карту или токен должен быть загружен апплет Datastore, позволяющий модулю jcpkcs11ds.dll (рекомендуемая версия — 1.1.3.20) производства компании «Аладдин Р.Д.» работать с картой или токеном.

Для администрирования токенов JaCarta LT на компьютере должно быть установлено ПО «Единый Клиент JaCarta» компании «Аладдин Р.Д.» (рекомендуемая версия — 2.9.0.1531).

При использовании JaCarta LT возможна аутентификация только по персональному ключу на устройстве.

Siemens CardOS

Смарт-карты CardOS/M4.01a, CardOS V4.3B, CardOS V4.2B, CardOS V4.2B DI, CardOS V4.2C, CardOS V4.4 производства компании
Atos (Siemens)

На компьютере должно быть установлено ПО Siemens CardOS API V5.0.

Смарт-карты должны быть особым образом размечены. Обратитесь к производителю устройств.

eToken GOST/

JaCarta GOST

Персональные электронные ключи eToken ГОСТ и JaCarta ГОСТ , а также персональные электронные ключи и смарт-карты JaCarta PKI/ГОСТ производства компании «Аладдин Р.Д.»

Для работы с указанными устройствами на компьютере должно быть установлено ПО «Единый Клиент JaCarta» компании «Аладдин Р.Д.» (рекомендуемая версия — 2.9.0.1531).

Перенос ключей подписи с устройств и на устройства данного семейства невозможен, так как на устройствах используется аппаратная криптография с неизвлекаемым ключом.

Устройства JaCarta PKI/ГОСТ определяются как принадлежащие одновременно к семействам JaCarta и eToken GOST/JaCarta GOST. Во избежание возникновения проблем рекомендуется запретить опрос неиспользуемого семейства устройств.

Перенос ключей подписи на данный тип устройств невозможен.

Rutoken ECP/

Rutoken Lite

Электронные идентификаторы Рутокен ЭЦП и Рутокен Lite производства компании «Актив»

На компьютере должны быть установлены драйверы Rutoken (рекомендуемая версия — 4.2.2.0).

Перенос ключей подписи с устройств, а также на устройства Рутокен ЭЦП невозможен, так как на устройствах используется аппаратная криптография с неизвлекаемым ключом.

При использовании Rutoken Lite возможна аутентификация только по персональному ключу на устройстве.

Rutoken/

Rutoken S

Электронные идентификаторы Рутокен и Рутокен S производства компании «Актив»

На компьютере должны быть установлены драйверы Rutoken (рекомендуемая версия — 4.2.2.0).

eToken Aladdin

Персональные электронные ключи Gemalto SafeNet eToken 5100/5105, 5200/5205, 5110, 7300,
смарт-карта Gemalto SafeNet eToken 4100 производства компании Gemalto (SafeNet)

Персональные электронные ключи eToken PRO (Java), eToken PRO,
смарт-карты
eToken PRO (Java), eToken PRO,
JaCarta PRO производства компании «Аладдин Р.Д.»

Если компьютер работает под управлением ОС Windows 10, на нем должно быть установлено ПО SafeNet Authentication Client (рекомендуемая версия — 10.0.43).

Если компьютер работает под управлением другой ОС, на нем должно быть установлено либо ПО PKI Client версии 5.1 SP1, либо ПО SafeNet Authentication Client (рекомендуемая версия — 10.0.43).

Смарт-карта eToken PRO может использоваться с любым стандартным PC/SC‑совместимым устройством считывания карт.

Для работы смарт-карты JaCarta PRO на компьютере должно быть установлено ПО JC-PROClient версии 1.0.6 и должен быть включен режим совместимости с eToken.

Примечание. Если вам необходимо работать с устройством из семейства eToken Aladdin, а также с устройством из семейства JaCarta, JCDS или eToken GOST/JaCarta GOST, то во избежание появления ошибок при выполнении криптографических операций не устанавливайте на компьютер одновременно ПО «Единый Клиент JaCarta» и ПО SafeNet Authentication Client.

Примечание. Список поддерживаемых операционных систем для каждого из приведенных устройств вы найдете на официальном веб-сайте производителя этого устройства.


Алгоритмы и функции, поддерживаемые внешними устройствами

В следующей таблице перечислены криптографические алгоритмы, поддерживаемые внешними устройствами, приведена информация о возможности использования устройств в качестве датчиков случайных чисел, а также информация о поддержке стандарта PKCS#11.

Примечание. Стандарт PKCS#11 (также известный как Cryptoki) — один из стандартов семейства PKCS (Public Key Cryptography Standards — криптографические стандарты ключа проверки электронной подписи), разработанных компанией RSA Laboratories. Стандарт определяет независимый от платформы интерфейс API для работы с криптографическими устройствами идентификации и хранения данных.

Алгоритмы и функции, поддерживаемые внешними устройствами

Название семейства устройств в программе ViPNet CSP | Аппаратная поддержка российских криптографических алгоритмов (на устройстве) | Программная поддержка российских криптографических алгоритмов (в ViPNet CSP) | Использование ДСЧ в ViPNet CSP | Поддержка PKCS#11
ESMART Token | ESMART Token — отсутствует; ESMART Token ГОСТ — ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 (может не поддерживаться на старых устройствах) | ESMART Token — ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 ESMART Token ГОСТ — отсутствует | Нет | Да
Infotecs Software Token | ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 (изолированная программная реализация) | отсутствует | Нет | Да
A-Key | aKey S1000, aKey S1003, aKey S1004 — ГОСТ Р 34.10-2012; aKey S1000, aKey S1003 — ГОСТ Р 34.10-2001 | отсутствует | Нет | Да
ViPNet HSM | ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 | отсутствует | Нет | Да
JaCarta | отсутствует | ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 | Нет | Да
JCDS | отсутствует | ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 | Нет | Да
Siemens CardOS | отсутствует | ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 | Нет | Да
eToken GOST/ JaCarta GOST | ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 (короткий ключ) | отсутствует | Да | Да
Rutoken ECP/ Rutoken Lite | Рутокен ЭЦП — ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 (короткий ключ); Рутокен Lite — отсутствует | Рутокен ЭЦП — отсутствует; Рутокен Lite — ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 | ЭЦП — да Lite — нет | Да
Rutoken/ Rutoken S | отсутствует | ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 | Нет | Да
eToken Aladdin | отсутствует | ГОСТ Р 34.10-2001, ГОСТ Р 34.10-2012 | Нет | Да

Примечание. Шифрование поддерживается не всеми перечисленными устройствами. Для получения более подробной информации см. документацию по необходимому устройству.


Глоссарий

SQL-сервер

Сервер базы данных, который работает под управлением программного обеспечения Microsoft SQL Server.

ViPNet Administrator

Набор программного обеспечения для администрирования сети ViPNet, включающий в себя серверное и клиентское приложения ViPNet Центр управления сетью, а также программу ViPNet Удостоверяющий и ключевой центр.

ViPNet Удостоверяющий и ключевой центр (УКЦ)

Программа, входящая в состав программного обеспечения ViPNet Administrator. Администратор УКЦ формирует и обновляет ключи для сетевых узлов ViPNet, а также управляет сертификатами и списками аннулированных сертификатов.

ViPNet Центр управления сетью (ЦУС)

ViPNet Центр управления сетью — это программа, входящая в состав программного обеспечения ViPNet Administrator. Предназначена для создания и управления конфигурацией сети и позволяет решить следующие основные задачи:

  • построение виртуальной сети (сетевые объекты и связи между ними, включая межсетевые);
  • изменение конфигурации сети;
  • формирование и рассылка справочников;
  • рассылка ключей узлов и ключей пользователей;
  • формирование информации о связях пользователей для УКЦ;
  • задание полномочий пользователей сетевых узлов ViPNet.
Администратор сети ViPNet

Лицо, отвечающее за управление сетью ViPNet, создание и обновление справочников и ключей для сетевых узлов ViPNet, настройку межсетевого взаимодействия с доверенными сетями и обладающее правом доступа к программе ViPNet Центр управления сетью и (или) ViPNet Удостоверяющий и ключевой центр.

Аккредитованный удостоверяющий центр

Удостоверяющий центр, прошедший аккредитацию в уполномоченном федеральном органе исполнительной власти в соответствии с требованиями Федерального закона от 6 апреля 2011г. № 63-ФЗ «Об электронной подписи».

Аутентификация

Процесс идентификации пользователя, как правило, на основании его учетной записи. Аутентификация служит для подтверждения того, что входящий в систему пользователь является тем, за кого себя выдает, но процесс аутентификации не затрагивает права доступа пользователя (в отличие от авторизации).

Вышестоящий удостоверяющий центр

Удостоверяющий центр, который является вышестоящим по отношению к другому удостоверяющему центру в иерархической системе доверительных отношений между удостоверяющими центрами. При этом может быть подчиненным по отношению к третьему удостоверяющему центру, если не является головным.

Квалифицированный сертификат

Сертификат ключа проверки электронной подписи, выданный аккредитованным удостоверяющим центром или доверенным лицом аккредитованного удостоверяющего центра либо федеральным органом исполнительной власти, уполномоченным в сфере использования электронной подписи.

Клиент (ViPNet-клиент)

Сетевой узел ViPNet, который является начальной или конечной точкой передачи данных. В отличие от координатора клиент не выполняет функции маршрутизации трафика и служебной информации.

Ключ проверки электронной подписи

В соответствии с федеральным законом N 63-ФЗ «Об электронной подписи» от 6 апреля 2011 г. ключом проверки электронной подписи называется открытый ключ, который является не секретной частью пары асимметричных ключей и представляет собой уникальную последовательность символов, однозначно связанную с закрытым ключом и предназначенную для проверки подлинности электронной подписи.

Ключ электронной подписи

В соответствии с федеральным законом N 63-ФЗ «Об электронной подписи» от 6 апреля 2011 г. ключом электронной подписи называется закрытый ключ, который является секретной частью пары асимметричных ключей и представляет собой уникальную последовательность символов, предназначенную для создания электронной подписи.

Ключи пользователя ViPNet

Совокупность ключей, которые необходимы пользователю для аутентификации в сети ViPNet и шифрования других ключей, и к которым имеет доступ только данный пользователь.

Ключи пользователя могут содержать:

  • действующий персональный ключ пользователя;
  • ключ электронной подписи и соответствующий ему сертификат ключа проверки электронной подписи;
  • хэш пароля пользователя.

Содержимое ключей пользователя формируется в зависимости от типа аутентификации пользователя.

Ключи узла ViPNet

Совокупность ключей, с использованием которых производится шифрование трафика, служебной информации и писем программы ViPNet Деловая почта.

Координатор (ViPNet-координатор)

Сетевой узел, представляющий собой компьютер с установленным программным обеспечением координатора (ViPNet Coordinator) или специальный программно-аппаратный комплекс. В рамках сети ViPNet координатор выполняет серверные функции, а также маршрутизацию трафика и служебной информации.

Лицензия на сеть

Разрешение на пользование определенным набором функций продуктовой линейки ViPNet. В частности, лицензия на сеть ViPNet определяет следующее: номер сети, максимальное количество координаторов и клиентов, максимальное суммарное количество адресов, туннелируемых координаторами сети, максимальное количество узлов, на которые можно добавить ту или иную роль, максимальную разрешенную версию программного обеспечения ViPNet, срок действия лицензии и другие параметры.

Мастер-ключ

Ключ, который администратор сети ViPNet использует для формирования симметричных ключей пользователей и узлов. В сети ViPNet формируется три вида мастер-ключей:

  • мастер-ключ ключей обмена;
  • мастер-ключ ключей защиты ключей обмена;
  • мастер-ключ персональных ключей пользователей.

Мастер-ключ формируется с помощью датчика случайных чисел. Он хранится в программе ViPNet Удостоверяющий и ключевой центр в полной секретности, поскольку компрометация мастер-ключа приводит к компрометации всех ключей, сформированных на его основе.

Межсетевой экран

Устройство на границе локальной сети, служащее для предотвращения несанкционированного доступа из одной сети в другую. Межсетевой экран проверяет весь входящий и исходящий IP-трафик, после чего принимается решение о возможности дальнейшего направления трафика к пункту назначения. Межсетевой экран обычно осуществляет преобразование внутренних адресов в адреса, доступные из внешней сети (выполняет NAT).

Обновление ключей узла

Совокупность файлов, к которым относятся справочники сертификатов администраторов УКЦ (файл *.trl), списки аннулированных сертификатов своей и доверенных сетей (файлы *.crl, *.p7s), контрольные суммы паролей администраторов, корневые сертификаты администраторов доверенных сетей и служебная информация о пользователе узла, на котором обновляются ключи (право подписи). Фактически, обновление ключей узла является неполным вариантом ключей узла ViPNet.

Подчиненный удостоверяющий центр

Удостоверяющий центр, сертификат администратора которого заверен вышестоящим удостоверяющим центром.

Сертификат издателя

Сертификат удостоверяющего центра, которым заверяются издаваемые сертификаты.

Сертификат ключа проверки электронной подписи

Сертификат ключа проверки — это электронный документ или документ на бумажном носителе, выданный удостоверяющим центром либо доверенным лицом удостоверяющего центра и подтверждающий принадлежность ключа проверки электронной подписи владельцу сертификата ключа проверки электронной подписи.

Сетевой узел ViPNet

Узел, на котором установлено программное обеспечение ViPNet, зарегистрированный в программе ViPNet Центр управления сетью.

Сеть ViPNet

Логическая сеть, организованная с помощью программного обеспечения ViPNet и представляющая собой совокупность сетевых узлов ViPNet.

Сеть ViPNet имеет свою адресацию, позволяющую наладить обмен информацией между ее узлами. Каждая сеть ViPNet имеет свой уникальный номер (идентификатор).

Список аннулированных сертификатов (CRL)

Список сертификатов, которые до истечения срока их действия были аннулированы или приостановлены администратором Удостоверяющего центра и потому недействительны на момент, указанный в данном списке аннулированных сертификатов.

Справочники

Набор файлов, содержащих информацию об объектах сети ViPNet, в том числе об их именах, идентификаторах, адресах, связях. Эти файлы формируются в программе ViPNet Центр управления сетью, предназначенной для создания структуры и конфигурирования сети ViPNet.

Справочники и ключи

Справочники, ключи узла и ключи пользователя.

Транспортный модуль (MFTP)

Компонент программного обеспечения ViPNet, предназначенный для обмена информацией в сети ViPNet.

Удостоверяющий центр

Организация, осуществляющая выпуск сертификатов ключей проверки электронной подписи, а также сертификатов другого назначения.

Электронная подпись

Информация в электронной форме, которая присоединена к другой информации в электронной форме (подписываемой информации) или иным образом связана с такой информацией и которая используется для определения лица, подписывающего информацию.

Электронная рулетка

Встроенный компонент программного обеспечения ViPNet, который позволяет инициализировать датчик случайных чисел на основе действий пользователя. Полученная последовательность используется при формировании ключей узла.