ViPNet Administrator

In diesem Abschnitt:

Über dieses Dokument

Über das Programm

Systemanforderungen

Lieferumfang

Kontakt

Inhalt

Über dieses Dokument

Allgemeine Informationen

Installation der ViPNet Administrator Software

Arbeitsbeginn

Update der ViPNet Administrator Software

Deinstallieren der ViPNet Administrator Software

Mögliche Störungen

Regionaleinstellungen

Externe Datenträger


Über dieses Dokument

Dieses Dokument enthält eine ausführliche Beschreibung des Installations- und Ersteinstellungsprozesses von den Komponenten der Software ViPNet Administrator. Es werden Installationsschemen dargestellt und Empfehlungen zur Bereitstellung der Komponenten gegeben. Auch sind Informationen zum Update der in ViPNet Administrator enthaltenen Programmen gegeben und Lösungen möglicher Probleme beschrieben.

In diesem Abschnitt:

Zielgruppe

Verwendete Konventionen


Zielgruppe

Dieses Dokument ist für die Administratoren bestimmt, die sich mit der Installation, Update und Ersteinstellung der Software ViPNet Administrator® beschäftigen.


Verwendete Konventionen

Weiter unten sind Konventionen aufgeführt, die im gegebenen Dokument zur Kennzeichnung wichtiger Informationen verwendet werden.

Symbole, die für Anmerkungen benutzt werden

Symbol | Beschreibung
 | Achtung! Dieses Symbol weist auf einen Vorgang hin, der für die Daten- oder Systemsicherheit wichtig ist.
 | Hinweis. Dieses Symbol weist auf einen Vorgang hin, der es Ihnen ermöglicht, Ihre Arbeit mit dem Programm zu optimieren.
 | Tipp. Dieses Symbol weist auf zusätzliche Informationen hin.

Notationen, die zur Kennzeichnung von Informationen im Text verwendet werden

Notation | Beschreibung
Name | Namen von Elementen der Benutzeroberfläche. Beispiele: Fensterüberschriften, Feldnamen, Schaltflächen oder Tasten.
Taste+Taste | Tastenkombinationen. Zum Betätigen von Tastenkombinationen sollte zunächst die erste Taste gedrückt und dann, ohne die erste Taste zu lösen, die zweite Taste gedrückt werden.
Menü > Untermenü > Befehl | Hierarchische Abfolge von Elementen. Beispiele: Menüeinträge oder Bereiche der Navigationsleiste.
Code | Dateinamen, Pfade, Fragmente von Textdateien und Codeabschnitten oder Befehle, die aus der Befehlszeile ausgeführt werden.


Über das Programm

Die Software ViPNet Administrator® ist zum Administrieren der ViPNet Netzwerke bestimmt und besteht aus zwei Komponenten:

  • ViPNet Network Control Center (NCC).
  • ViPNet Key and Certification Authority (KCA).

ViPNet Network Control Center ist zum Gestalten der Struktur eines privaten ViPNet Netzwerks, Einstellen der Parameter der Netzwerkknoten, Registrieren der Benutzer auf den Netzwerkknoten uns Steuern der Netzwerkobjekte bestimmt.

ViPNet Key and Certification Authority ist zum Ausstellen und Verwalten der Zertifikate des öffentlichen Schlüssels bestimmt Dieses Programm übt die Funktionen der Zertifizierungsstelle aus und stellt die zur Arbeit im ViPNet Netzwerk notwendigen Schlüssel zur Verfügung.


Systemanforderungen

Zur Installation der Programme, die Teil der ViPNet Administrator Software sind, müssen die Computer mit einer Reihe der Anforderungen übereinstimmen.

Der Computer, auf dem mehrere Programme von ViPNet Administrator zu installieren sind, muss den maximalen von den angegebenen Anforderungen entsprechen.

In diesem Abschnitt:

ViPNet Network Control Center

ViPNet Key and Certification Authority


ViPNet Network Control Center

In diesem Abschnitt:

Server-Anwendung

Client-Anwendung


Server-Anwendung

Anforderungen an die Hardware des Computers zur Installation der Server-Anwendung von ViPNet Network Control Center:

  • Prozessor: Intel Core 2 Quad oder ein anderer x86-kompatibler‑Prozessor ähnlicher Leistung mit mindestens vier Kernen wird empfohlen.
  • Arbeitsspeicher: mindestens 1 GB.

    Hinweis. Bei vielen Netzwerkknoten und Verbindungen im ViPNet Netzwerk wird es empfohlen, einen Computer mit höherer Leistung zu verwenden:

    • Prozessor: ein Intel Core i7 oder ein anderer x86-kompatibler Prozessor ähnlicher Leistung mit mindestens acht Kernen wird empfohlen.
    • Arbeitsspeicher: mindestens 16 GB.
    • Version von Microsoft SQL Server jünger als Express Edition.

  • Freier Festplattenspeicher: mindestens 20 GB.
  • Betriebssystem: Windows 7 SP1 (32/64-Bit), Server 2008 R2 (64-Bit), Windows 8 (32/64-Bit), Server 2012 (64-Bit), Windows 8.1 (32/64-Bit), Server 2012 R2 (64-Bit).

    Im Betriebssystem sollte das neueste Updatepaket installiert sein.

  • Falls Internet Explorer verwendet wird: Version 8.0 oder höher.

Hinweis. Vor der Installation der Server-Anwendung ViPNet Network Control Center auf dem Computer mit Betriebssystem Windows 8, Server 2012, Windows 8.1 bzw. Server 2012 R2 SP1 überprüfen Sie, dass die Komponente von Windows Optionen .Net Framework 3.5 aktiviert ist.

Zur Installation und zum Betrieb der Server-Anwendung von ViPNet Network Control Center muss auf dem Computer folgende Software der dritten Hersteller installiert werden:

  • Auf dem Computer müssen folgende Anwendungen installiert werden:
    • Microsoft .NET Framework Version 4.5 (Software-Plattform).
    • Visual C++ 2010 Redistributable Package (Komponentensatz der Laufzeitumgebung der Bibliotheken von Visual C++).

    Die angegebenen Anwendungen sind im Lieferumfang der Software ViPNet Network Control Center enthalten.

  • Zum Anordnen der Datenbank auf dem Computer mit Server-Anwendung bzw. auf einem anderen, über das Netzwerk zugänglichen Computer muss ein Datenbankverwaltungssystem (DBVS) installiert werden. Es werden folgende Versionen von DBVS unterstützt:
    • Microsoft SQL Server 2008 SP3 und jünger.
    • Microsoft SQL Server 2008 R2 SP1 und jünger.
    • Microsoft SQL Server 2012.
    • Microsoft SQL Server 2014.

    Die Version von den angegebenen DBVS kann beliebig sein, einschließlich Express Edition. Im Lieferumfang der Software ViPNet Network Control Center ist das DBVS Microsoft SQL Server 2014 Express enthalten. Bei Bedarf kann es zusammen mit der Server-Anwendung automatisch installiert werden.

Achtung! Beim Betrieb von ViPNet Network Control Center ist die Ausgabe von Sicherheit-Updates für die angegebene Software der Dritten zurückzuverfolgen und diese Updates sind rechtzeitig zu installieren.


Client-Anwendung

Anforderungen an die Hardware des Computers zur Installation der Client-Anwendung von ViPNet Network Control Center:

  • Prozessor: ein Intel Core 2 Duo oder ein anderer x86-kompatible‑Prozessoren mit mindestens zwei Kernen wird empfohlen.
  • Arbeitsspeicher: mindestens 1 GB (bzw. mindestens 2 GB bei der Verwendung von 64-Bit-Versionen vom Betriebssystem Microsoft Windows).
  • Freier Festplattenspeicher: mindestens 1 GB.
  • Betriebssystem: Windows 7 (32/64-Bit), Server 2008 R2 (64-Bit), Windows 8 (32/64-Bit), Server 2012 (64-Bit), Windows 8.1 (32/64-Bit), Server 2012 R2 (64-Bit).

    Im Betriebssystem sollte das neueste Updatepaket installiert sein.

  • Falls Internet Explorer verwendet wird: Version 11.0 oder höher.

Hinweis. Vor der Installation der Server-Anwendung ViPNet Network Control Center auf dem Computer mit Betriebssystem Windows 8, Server 2012, Windows 8.1 bzw. Server 2012 R2 SP1 überprüfen Sie, dass die Komponente von Windows Optionen .Net Framework 3.5 aktiviert ist.

Zur Installation und zum Betrieb der Client-Anwendung von ViPNet Network Control Center muss auf dem Computer folgende Software der dritten Hersteller installiert werden:

  • Microsoft .NET Framework Version 4.5 (Software-Plattform).
  • Visual C++ 2010 Redistributable Package (Komponentensatz der Laufzeitumgebung der Bibliotheken von Visual C++).

Die angegebenen Anwendungen sind im Lieferumfang der Software ViPNet Network Control Center enthalten.

Achtung! Beim Betrieb von ViPNet Network Control Center ist die Ausgabe von Sicherheit-Updates für die angegebene Software der Dritten zurückzuverfolgen und diese Updates sind rechtzeitig zu installieren.


ViPNet Key and Certification Authority

Anforderungen an die Hardware zur Installation von ViPNet Key and Certification Authority:

  • Prozessor: ein Intel Core 2 Duo oder ein anderer x86-kompatible‑Prozessoren mit mindestens zwei Kernen wird empfohlen.
  • Arbeitsspeicher: mindestens 1 GB (bzw. mindestens 2 GB bei der Verwendung von 64-Bit-Versionen vom Betriebssystem Microsoft Windows).
  • Freier Festplattenspeicher: mindestens 1 GB.
  • Betriebssystem: Windows 7 (32/64-Bit), Server 2008 R2 (64-Bit), Windows 8 (32/64-Bit), Server 2012 (64-Bit), Windows 8.1 (32/64-Bit), Server 2012 R2 (64-Bit).

    Im Betriebssystem sollte das neueste Updatepaket installiert sein.

  • Falls Internet Explorer verwendet wird: Version 8.0 oder höher.


Lieferumfang

Der Lieferumfang der ViPNet Administrator Software schließt das Folgende ein:

  • Installationsdatei der Server-Anwendung von ViPNet Network Control Center.
  • Installationsdatei der Client-Anwendung von ViPNet Network Control Center.
  • Anwendungen der Dritten, die zum Betrieb der Komponenten von ViPNet Network Control Center erforderlich sind.
  • Installationsdatei von ViPNet Key and Certification Authority.
  • Handbücher im PDF-Format, u. a.:
    • „ViPNet Administrator. Installationshandbuch“.
    • „ViPNet Administrator. Lizenzvereinbarungen für Komponenten dritter Hersteller“.
    • „ViPNet Network Control Center. Administratorhandbuch“.
    • „ViPNet Key and Certification Authority. Administratorhandbuch“.
    • „Hauptbegriffe und -Definitionen. Anhang zur ViPNet Dokumentation“.
    • „Druck der Zertifikate. Anhang zur ViPNet Dokumentation“.

Hinweis. Siehe die Liste von den zum Betrieb von NCC Anwendungen der Dritten im Anschnitt Systemanforderungen.


Kontakt

FAQ und andere Hilfsinformation

Informationen über ViPNet Produkte und Lösungen, gängige Fragen und andere nützliche Hinweise sind auf der Webseite von Infotecs zusammengefasst. Unter den aufgeführten Links können Sie zahlreiche Antworten auf mögliche während des Produktbetriebs auftretenden Fragen finden.

  • Allgemeine Geschäftsbedingungen
  • ViPNet Lösungen im Überblick
  • Frequently Asked Questions
  • ViPNet Wissensdatenbank

Kontakt

Bei Fragen zur Nutzung von ViPNet Software sowie möglichen Wünschen und Anregungen nehmen Sie Kontakt mit den Mitarbeitern der Firma Infotecs GmbH auf. Für die Lösung aufgetretener Problemfälle wenden Sie sich an den technischen Support.

  • E-Mail: support@infotecs.de.
  • Anfrage an den technischen Support via Internetseite
  • Support Hotline +49 (0) 30 206 43 66 22 (Tel.); +49 (0) 30 206 43 66 66 (Fax).


Allgemeine Informationen

In diesem Abschnitt:

Zusammensetzung der Software ViPNet Administrator

Bereitstellungsschemen von Komponenten der ViPNet Administrator Software

Verwendung von ViPNet Client zum Absenden der Daten an die Netzwerkknoten

Lizenz des ViPNet Netzwerks


Zusammensetzung der Software ViPNet Administrator

Die Software ViPNet Administrator besteht aus zwei Hauptkomponenten:

  • ViPNet Network Control Center (nachfolgend NCC genannt).
  • ViPNet Key and Certification Authority (nachfolgend KCA genannt).

ViPNet Network Control Center ist zum Gestalten der Struktur von ViPNet Netzwerken, Eingeben der Hauptparameter der Netzwerkknoten und Benutzer, zentralen Absenden von Schlüssel-, Adresslisten- und Softwareupdates an die ViPNet Netzwerkknoten bestimmt.

ViPNet Network Control Center schließt zwei Komponenten ein:

  • Server-Anwendung zur Arbeit mit der Datenbank, die vollständige Informationen über die Struktur und die Objekte des ViPNet Netzwerks enthält.
  • Client-Anwendung, die eine bequeme grafische Oberfläche zum Verwalten der ViPNet Netzwerkstruktur und Eigenschaften der Netzwerkobjekte darstellt.

    Es sind eine entfernte Verbindung der Client-Anwendung mit der Server-Anwendung sowie gleichzeitige Verbindung von mehreren Client-Anwendungen an die Server-Anwendung möglich.

ViPNet Key and Certification Authority ist zum Verwalten der Schlüsselstruktur des ViPNet Netzwerks sowie zum Ausstellen und Verwalten der Zertifikate des öffentlichen Schlüssels bestimmt. KCA kann nach seinen Hauptfunktionen in zwei Komponenten geteilt werden: Key Management Center und Zertifizierungsstelle.

Die Zusammenarbeit von NCC und KCA erfolgt mit Hilfe einer SQL-Datenbank. Die Programme sprechen die SQL-Datenbank unabhängig voneinander an, wo alle notwendigen Informationen gespeichert werden. Die in einem Programm vorgenommenen Änderungen werden im anderen Programm sofort dargestellt.

Zusammenarbeit der Komponenten der ViPNet Administrator Software


Bereitstellungsschemen von Komponenten der ViPNet Administrator Software

Vor der Installation der Software ViPNet Administrator wählen Sie die Computer aus, auf welchen folgende Komponenten bereitzustellen sind:

  • ViPNet Administrator Datenbank.
  • Server-Anwendung von ViPNet Network Control Center.
  • ViPNet Key and Certification Authority.
  • Eine oder mehrere Client-Anwendungen von ViPNet Network Control Center.

Die angegebenen Komponenten können auf einem oder mehreren Computern des Netzwerk in beliebiger Zusammensetzung installiert werden. Der grundsätzliche Unterschied zwischen den Bereitstellungsoptionen besteht in der Zuordnung der Komponenten und der Datenbank von ViPNet Administrator. Deshalb lassen sich zwei Hauptschemen der Bereitstellung von den Komponenten der Software ViPNet Administrator unterscheiden:

  1. Installation aller Komponenten von ViPNet Administrator auf einem Computer.
  2. Installation aller Komponenten von ViPNet Administrator auf verschiedenen Computern.

Bei der Verwendung von jedem Bereitstellungsschema können eine oder mehrere Client-Anwendungen von NCC auf beliebige Computer des Netzwerks. Die Installation der Server- und Client-Anwendungen von NCC ist sowohl auf demselben als auch auf verschiedenen Computern möglich. Bei der Installation auf verschiedene Computer schließt sich die Client-Anwendung an die Server-Anwendung entfernt an. Auch ist gleichzeitiger Anschluss von mehreren Client-Anwendungen an die Server-Anwendung möglich. Ausführliche Informationen über die Installationsverfahren der Client- und Server-Anwendungen von NCC sind im Abschnitt Bereitstellung der Client-Anwendung von ViPNet Network Control Center enthalten.

In diesem Abschnitt:

Installation der Komponenten von ViPNet Administrator auf einem Computer

Installation der Komponenten von ViPNet Administrator auf verschiedenen Computern

Bereitstellung der Client-Anwendung von ViPNet Network Control Center


Installation der Komponenten von ViPNet Administrator auf einem Computer

Dieses Schema ist am einfachsten und ist für kleinere Netzwerke mit einem Administrator geeignet, der sowohl mit dem NCC als auch mit KCA arbeitet. Es basiert auf der Installation von NCC, KCA und SQL-Server mit der Datenbank von ViPNet Administrator auf demselben Computer, deshalb sind zusätzliche Schwierigkeiten mit der Bereitstellung des SQL-Servers ausgeschlossen.

Installation der Server-Anwendung von NCC und KCA auf demselben Computer


Installation der Komponenten von ViPNet Administrator auf verschiedenen Computern

Sie können dieses Bereitstellungsschema dann benutzen, wenn in Ihrem Unternehmen ein SQL-Server bereitgestellt ist und es geplant wird, dass die Datenbank von ViPNet Administrator auf diesem Server anzuordnen ist. In diesem Fall werden alle übrigen Komponenten von ViPNet Administrator auch auf gesonderten Computern installiert (dies ist sinnvoll, wenn mehrere Administratoren das Netzwerk verwalten).

Installation der Server-Anwendung von NCC und KCA auf zwei verschiedenen Computern


Bereitstellung der Client-Anwendung von ViPNet Network Control Center

In den verhandelten Hauptanordnungsschemen der Software-Komponenten kann die Client-Anwendung von KCA auf beliebigem Computer des ViPNet Netzwerks installiert werden. Es bestehen folgende Möglichkeiten zur Installation der Anwendungen:

  • Server- und Client-Anwendungen von NCC können sowohl auf demselben als auch auf verschiedenen Computern installiert werden.
  • Die Client-Anwendung von NCC kann sowohl auf demselben als auch auf verschiedenen Computern installiert werden.

Die Installation von den Server- und Client-Anwendungen von NCC auf verschiedene Computer ermöglicht es, einen gesonderten leistungsfähigen Computer zum Bereitstellen der Server-Anwendung zu verwenden. Die Installation von Client-Anwendungen auf mehrere Computer ermöglicht das Administrieren im Mehrbenutzer-Modus. Sie können den Standort der Client-Anwendung von NCC unter Berücksichtigung von Bedürfnissen Ihres Unternehmens und von notwendiger Anzahl der Netzwerk-Administratoren auswählen.

Installationsoptionen der Anwendungen von NCC


Verwendung von ViPNet Client zum Absenden der Daten an die Netzwerkknoten

Zum Betrieb des ViPNet Netzwerks muss die Übertragung von Schlüsseln, Adresslisten, Zertifikaten und Softwareupdates vom Arbeitsplatz des Administrators an die Netzwerkknoten organisiert werden. Dies kann der ViPNet MFTP Modul ausüben, der Teil der Software ViPNet Client ist.

Die Software ViPNet Client muss auf den Computer mit der Server-Anwendung von ViPNet Network Control Center installiert werden. Auch soll zur Vereinfachung der Verbindungsherstellung ViPNet Client auf die Computer mit der Client-Anwendung von NCC und mit KCA installiert werden. Für die Zusammenarbeit mit der Software ViPNet Administrator 4.x sollte die Software ViPNet Client der Version 4.2 und jünger verwendet werden.

Hinweis. Die Installation der Software ViPNet Client auf einen gesonderten, ans Netzwerk nicht angeschlossenen Computer mit KCA ist nicht erforderlich, aber in diesem Fall muss auf dem Computer mit der Server-Anwendung von NCC in ViPNet Monitor (Teil der Software ViPNet Client) ein Netzwerkfilter zum Verbinden mit dem KCA-Netzwerkknoten erstellt werden.

Die Verwendung von ViPNet Client auf dem Computer mit der Server-Anwendung von NCC ermöglicht:

  • Schutz (Verschlüsselung ) des IP-Traffics zwischen dem Arbeitsplatz des Administrators und anderen Netzwerkknoten (siehe Schema unten).
  • Schutz des Arbeitsplatzes des Administrators gegen unbefugten Zugang bei der Arbeit in lokalen und globalen Netzwerken mit Hilfe der integrierten Firewall.

Verwendung des ViPNet Clients als Software zum Absenden der Daten an die Netzwerkknoten


Lizenz des ViPNet Netzwerks

Um ein ViPNet Netzwerk bereitzustellen, ist eine entsprechende Lizenz erforderlich, die bei Infotecs GmbH beschafft werden kann.

Die Lizenz für das ViPNet Netzwerk befindet sich in einer speziellen Datei *.itcslic oder infotecs.reg, und ohne diese Datei ist der Betrieb der ViPNet Administrator Software unmöglich.

Die Lizenzdatei enthält folgende Informationen:

  • Die Nummer des ViPNet Netzwerks und die Nummern der untergeordneten Netzwerke — falls die Lizenz die Einrichtung einer Hierarchie der ViPNet Netzwerke voraussetzt.
  • Angaben des Inhabers des Netzwerks.
  • Die Möglichkeit der Benutzung von Funktionen der Zertifizierungsstelle und maximale Anzahl der Zertifikate des öffentlichen Schlüssels, die in KCA für externe Benutzer und ViPNet Benutzer ausgestellt werden kann.
  • Die Liste der Rollen, die zur Benutzung im ViPNet Netzwerk erlaubt sind, und Beschränkungen der Anzahl von Netzwerkknoten mit verschiedenen Rollen.
  • Einschränkungen der Software-Version und -Verwendungsdauer für die Rollen.
  • Allgemeine Gültigkeitsdauer der Lizenz.

Es gibt drei Typen der Lizenze:

  • Mit Unterstützung von ViPNet Netzwerk-Hierarchie.
  • Ohne Unterstützung von ViPNet Netzwerk-Hierarchie.

Falls Sie über eine Lizenz mit Unterstützung der ViPNet Netzwerk-Hierarchie verfügen, können Sie neben dem Hauptnetzwerk auch ein bzw. mehrere untergeordnete Netzwerke erstellen. Für ausführliche Informationen siehe Dokument „ViPNet Network Control Center. Administratorhandbuch“.

Beim Wachsen der Anzahl von Netzwerk-Clients kann eine Erweiterung der Lizenz erforderlich werden. Dazu wenden Sie sich an den Vertreter von Infotecs GmbH und bestellen Sie eine neue Lizenz, zusätzlich geben Sie die Nummer des ViPNet Netzwerks und die gewünschten Parameter neuer Lizenz an. Wählen Sie den Punkt Über in der Client-Anwendung von NCC oder im Menü Hilfe von KCA aus, um die Netzwerknummer zu bestimmen.

Nach dem Bearbeiten der Anfrage auf die Lizenzerweiterung erhalten Sie eine neue Datei *.itcslic oder infotecs.reg. Wählen Sie im Fenster der Client-Anwendung von ViPNet Network Control Center im Menü Lizenz den Punkt Lizenz aktualisieren aus und geben Sie den Pfad zur aktualisierten Lizenzdatei an; danach starten Sie das Programm erneut. Nach dem Neustart des Programms wird die erweiterte Lizenz verwendet.


Installation der ViPNet Administrator Software

In diesem Abschnitt:

Vorgehensweise bei der Installation von Komponenten der ViPNet Administrator Software

Informationen für den SQL-Administrator

Installation der Server-Anwendung von ViPNet Network Control Center

Installation der Client-Anwendung von ViPNet Network Control Center

Installation von ViPNet Key and Certification Authority

Installation von Updates für die Software der Dritten


Vorgehensweise bei der Installation von Komponenten der ViPNet Administrator Software

Zur erfolgreichen Bereitstellung der ViPNet Administrator Software sind alle Aktionen aus der unten angegebenen Liste auszuführen.

Achtung! Die Programme ViPNet Network Control Center und ViPNet Key and Certification Authority verschiedener Versionen können miteinander inkompatibel sein.

Vorgehensweise bei der Installation von Komponenten der ViPNet Administrator Software

Aktion

Link

Planen Sie das Bereitstellungsschema von den Komponenten der ViPNet Administrator Software.

Bereitstellungsschemen von Komponenten der ViPNet Administrator Software

Berechnen Sie die Anzahl von Computern, wo die Client-Anwendung von NCC bereitzustellen ist.

Bereitstellung der Client-Anwendung von ViPNet Network Control Center

Bereiten Sie erforderliche Anzahl von Computern vor und schließen Sie diese an physisches Netzwerk an.

Überprüfen Sie, dass Sie über eine Lizenzdatei für das ViPNet Netzwerk *.itcslic bzw. infotecs.reg verfügen.

Lizenz des ViPNet Netzwerks

Stellen Sie den SQL-Server auf einen gesonderten Computer bereit, falls es erforderlich ist, dass die Datenbank gesondert von den Komponenten von ViPNet Administrator installiert wird.

Siehe Betriebsunterlagen des SQL-Servers.

Installieren Sie die Server-Anwendung von NCC unter Berücksichtigung von der ausgewählten Installationsoption der NCC-Anwendungen.

Falls die Datenbank von ViPNet Administrator auf einem gesonderten Computer bereitgestellt ist, stellen Sie die Verbindung zur Datenbank während der Installation der Server-Anwendung her.

Installation der Server-Anwendung von ViPNet Network Control Center

Installieren Sie die Client-Anwendung von NCC unter Berücksichtigung von der ausgewählten Installationsoption der NCC-Anwendungen.

Installation der Client-Anwendung von ViPNet Network Control Center

Installieren Sie die Sicherheitsupdates für die verwendete Software der Dritten

Installation von Updates für die Software der Dritten

Installieren Sie KCA unter Berücksichtigung vom ausgewählten Bereitstellungsschema der Komponenten von der ViPNet Administrator Software.

Installation von ViPNet Key and Certification Authority

Installieren Sie die Software ViPNet Client der Version 4.2 und jünger auf die Computer mit Server- und Client-Anwendungen von NCC sowie auf dem Computer mit KCA.

Siehe Abschnitt „Installation der Software ViPNet Client“ im Dokument „ViPNet Client for Windows. Benutzerhandbuch“.

Führen Sie den Erststart der Client-Anwendung von NCC aus und richten Sie die ViPNet Netzwerkstruktur ein.

Erststart von ViPNet Network Control Center

Führen Sie den Erststart und die primäre Initialisierung von KCA aus.

Erststart von ViPNet Key and Certification Authority

Primäre Initialisierung von ViPNet Key and Certification Authority

Tipp. Wir empfehlen, die Liste auszudrucken, und die einzelnen Schritte nach ihrer Durchführung zu markieren


Informationen für den SQL-Administrator

In der ViPNet Administrator Software wird die Server-Anwendung ViPNet Network Control Center und das Programm ViPNet Key and Certification Authority tauschen die Daten über die Datenbank des SQL-Servers miteinander aus, in der die Informationen über die ViPNet Netzwerkstruktur und -Einstellungen gespeichert wird. Während der Arbeit mit Hilfe von ViPNet Key and Certification Authority können Sie Sicherungskopien dieser Datenbank erstellen, um bei Bedarf die notwendige Netzwerkkonfiguration wiederherzustellen (für ausführliche Informationen siehe Dokument „ViPNet Key and Certification Authority. Administratorhandbuch“, Abschnitt „Administrative Funktionen“).

Die Datenbank wird automatisch bei der Installation der Server-Anwendung von NCC erstellt. Zur Speicherung der Datenbank können Sie bestehendes benanntes Exemplar des SQL-Servers (instance) verwenden, das auf einem lokalen oder entfernten Computer installiert ist. Unterstützte Versionen des SQL-Servers sind im Abschnitt Server-Anwendung angegeben.

Falls kein geeigneter SQL-Server vorhanden ist, können Sie einen SQL-Server aus dem Lieferumfang von ViPNet Administrator installieren. In diesem Fall wird bei der Installation der Server-Anwendung von NCC die englische Version von Microsoft SQL Server 2014 Express installiert und ein benanntes Exemplar des SQL-Servers mit den Standardnamen WINNCCSQL erstellt. Sie können den Namen während der Installation der Server-Anwendung von NCC ändern.

Hinweis. Die Installation des benannten Exemplars auf den Computer, wo ein anderes Exemplar früher bereits installiert wurde, beeinflusst seinen Betrieb nicht. Zwei Exemplare werden parallel betrieben.

Bei der Installation der Server-Anwendung von NCC werden auf dem SQL-Server erstellt:

  • Datenbank mit dem Namen ViPNetAdministrator.
  • Datenbank mit dem Namen ViPNetJournals, wo die Audit-Logdateien von ViPNet Network Control Center gespeichert werden.
  • Benutzerkonto mit Datenbank-Administratorrechten für den Benutzer, vom dessen Namen die Installationsdatei der Server-Anwendung von NCC gestartet wurde.
  • Zwei Benutzerkonten von den Benutzern KcaUser und NccUser, unter welchen die Verbindung von KCA bzw. von der Server-Anwendung mit der Datenbank erfolgt. Die Verbindung der Server-Anwendung von NCC wird beim Erststart von NCC hergestellt. Ausführliche Beschreibung der Verbindung von NCC mit der Datenbank ist im Abschnitt Primäre Initialisierung von ViPNet Key and Certification Authority dargelegt.

Die Parameter der erstellten Datenbank sind in der Tabelle unten angegeben.

Datenbankparameter

Parameter | Parameterwert
Sortierparameter (collation) | Cyrillic_General_CI_AS
Wiederherstellungsmodell (recovery model) | Full

Achtung! Es wird nicht empfohlen, die Einstellungen der Datenbank zu ändern und Aktionen zur Verwaltung ihrer Struktur bzw. Information unmittelbar in der ViPNet Administrator Datenbank vorzunehmen. Solche Aktionen können zu ernsthaften Betriebsstörungen von ViPNet Administrator führen. Infotecs GmbH haftet für durch solche Aktionen verursachte Fehler nicht.

Das benannte Exemplar des SQL-Servers muss die in der unten angegebenen Tabelle enthaltenen Parameter haben. Bei der Installation des SQL-Servers aus dem Lieferumfang von ViPNet Administrator werden diese Parameter automatisch auf erforderliche Werte gesetzt.

Parameter des SQL-Servers

Parameter | Wert
FILESTREAM | FILESTREAM beim Zugang über Transact-SQL erlauben (Enable FILESTREAM for Transact-SQL access)
 | FILESTREAM beim E/A-Streamingzugang auf Dateien erlauben (Enable FILESTREAM for file I/O streaming access)
 | Streamingzugang auf die Daten von FILESTREAM für entfernte Clients erlauben (Allow remote clients to have streaming access to FILESTREAM data)
Shared Memory Protokoll | Aktiviert (Enabled)
Named Pipes Protokoll | Aktiviert (Enabled)
TCP/IP-Protokoll | Aktiviert (Enabled)
Status des Dienstes SQL Server Browser | Im Betrieb (Running)
Starttyp des Dienstes SQL Server Browser | Automatisch (Automatic)


Installation der Server-Anwendung von ViPNet Network Control Center

Nach der Wahl des Bereitstellungsschemas der Software ViPNet Administrator können Sie mit der Installation der Server-Anwendung von NCC anfangen.

Vor dem Beginn der Installation des Programms überprüfen Sie, dass Sie eine Installationsdatei der Server-Anwendung von ViPNet Network Control Center haben.

Zur Installation der Anwendung gehen Sie wie folgt vor:

  1. Starten Sie die Installationsdatei [image] aus dem Ordner des Installationssatzes der Server-Anwendung von ViPNet Network Control Center mit doppeltem Klicken.
  2. Im Fenster Installation von ViPNet Administrator [Network Control Center] wird es vorgeschlagen, notwendige Software zu installieren. Die Liste der notwendigen Software hängt von früher auf dem Computer installierten Programmen ab. Klicken Sie auf die Schaltfläche Weiter, um die Installation zu beginnen.

    Installation der notwendigen Software

    Hinweis. Die Installation der notwendigen Software kann eine lange Zeit in Anspruch nehmen.

  3. Falls nach der Installation ein Neustart des Computers erforderlich ist, zeigt das Programm eine entsprechende Meldung an. Starten Sie den Computer neu. Nach dem Neustart wird die Installation der Server-Anwendung von NCC automatisch fortgesetzt.
  4. Wählen Sie die Sprache für das Programm ViPNet Network Control Center im angezeigten Fenster aus und klicken Sie auf Weiter.

    Hinweis. In diesem Fall wird die Sprache für das Installationsprogramm von ViPNet Network Control Center sowie für die Oberfläche der Server- und Client-Anwendung von NCC ausgewählt.

  5. Machen Sie sich auf der Seite Lizenzvereinbarung mit dem Text der Lizenz vertraut. Beim Einverständnis aktivieren Sie entsprechendes Kontrollkästchen. Klicken Sie anschließend auf Weiter.
  6. Geben Sie die Datenbank-Verbindungsparameter auf der Seite Software installieren an. Falls Sie keinen Namen des bestehenden SQL-Servers angeben, wird auf dem Computer ein SQL-Server aus dem Lieferumfang installiert uns benanntes Exemplar mit dem Namen WINNCCSQL erstellt. Bei Bedarf können Sie anderen Namen des Exemplars angeben.

    Einstellung der Parameter zum Anschluss an die Datenbank

    Gehen Sie wie folgt vor, um ein bestehendes benanntes Exemplar des SQL-Servers zu verwenden:

    • Geben Sie im Feld Servername den Namen des bestehenden benannten Exemplars des SQL-Servers statt WINNCCSQL ein. Geben Sie statt des Punktes die IP-Adresse bzw. den DNS-Namen des entfernten Computers ein, falls der SQL-Server sich auf einem entfernten Computer befindet.
    • Wählen Sie im Feld Authentifizierung den Authentifizierungsmodus beim Verbinden mit dem SQL-Server aus. Falls der SQL-Server auf demselben Computer bereitgestellt worden ist, wird es empfohlen, die Option Windows-Authentifizierung auszuwählen. In diesem Fall erfolgt die Authentifizierung durch das Betriebssystem unter Verwendung vom Windows-Benutzerkonto. Bei entfernter Bereitstellung des SQL-Servers hängt der Authentifizierungsmodus von den auf diesem Server festgelegten Sicherheitsrichtlinien ab. Wählen Sie die Option Authentifizierung SQL Server aus und geben Sie den Namen und das Passwort des Benutzerkontos auf dem SQL-Server an, falls die Authentifizierung nach Kontoangaben des Benutzers des SQL-Servers erfolgt. Wenden Sie sich an den Administrator des SQL-Servers, um den Authentifizierungsmodus auf dem entfernten SQL-Server und die Kontoangaben anzufragen.
    • Klicken Sie auf der Schaltfläche Verbindung überprüfen, um die Verbindung mit dem SQL-Server zu überprüfen. Falls Sie einen Standort des SQL-Servers angegeben haben und dabei kein SQL-Server mit dem angegebenen Namen existiert bzw. verfügbar ist, wird eine Meldung angezeigt, dass die Verbindung mit der Datenbank mit den angegebenen Parametern unmöglich ist. Klicken Sie auf die Schaltfläche Schließen, überprüfen Sie, dass der ausgewählte Servername korrekt ist, und wiederholen Sie die Prüfung.
  7. Klicken Sie auf die Schaltfläche Einstellungen, falls Sie die Installationsparameter einstellen möchten, und geben Sie das Folgende an:
    • Pfad zum Installationsordner des Programms auf dem Computer.

      Standardmäßiger Installationsordner des Programms:

      C:\Program Files\InfoTeCS\ViPNet Administrator — für 32-Bit-Betriebssysteme;
      C:\Program Files (x86)\InfoTeCS\ViPNet Administrator — für 64-Bit-Betriebssysteme.

    • Benutzername und Name der Firma.
    • Name des Programmordners und sein Standort im Menü Start.
  8. Klicken Sie auf die Schaltfläche Weiter, um die Installation zu beginnen.

    Einstellung der Installationsparameter der Server-Anwendung des NCC

  9. Überprüfen Sie die Installationsparameter im angezeigten Fenster. Klicken Sie auf die Schaltfläche Jetzt installieren, um mit der Installation anzufangen.
  10. Falls die Datenbank von ViPNet Administrator auf einem gesonderten SQL-Server anzuordnen ist, geben Sie den Namen des bereitgestellten SQL-Servers an. Falls Sie keinen Namen des bestehenden SQL-Servers angegeben haben, wird eine Meldung mit einer Option zum Erstellen des Datenbankservers mit vorgegebenem Namen angezeigt. Klicken Sie auf die Schaltfläche Ja im Meldungsfenster, um den Server zu erstellen.
  11. Nach dem Erstellen des Datenbankservers ist der Neustart des Computers erforderlich; das Programm zeigt entsprechende Meldung an. Starten Sie den Computer neu. Nach dem Neustart wird die Installation der Server-Anwendung von NCC automatisch fortgesetzt.
  12. Wählen Sie die Sprache für das Programm ViPNet Network Control Center im angezeigten Fenster aus und klicken Sie auf Weiter.
  13. Klicken Sie auf die Schaltfläche Weiter auf der Seite Software installieren.
  14. Überprüfen Sie die Installationsparameter im angezeigten Fenster. Klicken Sie auf die Schaltfläche Jetzt installieren, um mit der Installation anzufangen.
  15. Nach der Beendigung der Installation klicken Sie auf die Schaltfläche Schließen.

Dadurch wird die Server-Anwendung von NCC auf dem Computer installiert. Weiter können Sie eine oder mehrere Client-Anwendungen von NCC installieren.


Installation der Client-Anwendung von ViPNet Network Control Center

Nach der Installation der Server-Anwendung von NCC installieren Sie eine oder mehrere Client-Anwendungen von NCC auf den Arbeitsplätzen der Administratoren des eingerichteten Netzwerks.

Vor dem Beginn der Installation des Programms überprüfen Sie, dass Sie eine Installationsdatei der Client-Anwendung von ViPNet Network Control Center haben.

Zur Installation der Anwendung gehen Sie wie folgt vor:

  1. Starten Sie die Installationsdatei [image] aus dem Ordner des Installationssatzes der Client-Anwendung von ViPNet Network Control Center mit doppeltem Klicken.
  2. Bei der Installation der Client-und Server-Anwendungen auf verschiedenen Computern wird es im Fenster Installation von ViPNet Administrator [Network Control Center] vorgeschlagen, notwendige Software zu installieren. Die Zusammensetzung der zu installierenden Software hängt von den auf dem Computer bereits vorhandenen Programmen ab.

    Installation der zusätzlichen Software

    Hinweis. Die Programmkomponenten, die zum Betrieb der Server-Anwendung notwendig sind, schließen die Komponenten ein, die zum Betrieb der Client-Anwendung notwendig sind. Deshalb ist keine wiederholte Installation von diesen Komponenten bei der Installation der Client-Anwendung auf demselben Computer wie die Server-Anwendung erforderlich.

  3. Klicken Sie auf die Schaltfläche Weiter, um die Installation zu beginnen.

    Hinweis. Die Installation der notwendigen Software kann eine lange Zeit in Anspruch nehmen.

  4. Falls nach der Installation ein Neustart des Computers erforderlich ist, zeigt das Programm eine entsprechende Meldung an. Starten Sie den Computer neu. Nach dem Neustart wird die Installation der Client-Anwendung von NCC automatisch fortgesetzt.
  5. Wählen Sie die Sprache für das Installationsprogramm ViPNet Network Control Center im angezeigten Fenster aus und klicken Sie auf Weiter.

    Hinweis. In diesem Fall wird die Sprache nur für das Installationsprogramm von ViPNet Network Control Center ausgewählt. Die Oberflächensprache der Client-Anwendung stimmt mit der Sprache überein, die für die Oberfläche der Server-Anwendung von NCC ausgewählt ist.

  6. Machen Sie sich auf der Seite Lizenzvereinbarung mit dem Text der Lizenz vertraut. Beim Einverständnis aktivieren Sie entsprechendes Kontrollkästchen. Klicken Sie anschließend auf Weiter.
  7. Klicken Sie auf die Schaltfläche Einstellen auf der Seite Installationsart, falls Sie die Installationsparameter einstellen möchten, und geben Sie das Folgende an:
    • Pfad zum Installationsordner des Programms auf dem Computer.

      Standardmäßiger Installationsordner des Programms:

      C:\Program Files\InfoTeCS\ViPNet Administrator — für 32-Bit-Betriebssysteme;
      C:\Program Files (x86)\InfoTeCS\ViPNet Administrator — für 64-Bit-Betriebssysteme.

    • Benutzername und Name der Firma.
    • Name des Programmordners und sein Standort im Menü Start.
  8. Klicken Sie auf die Schaltfläche Jetzt installieren, um mit der Installation anzufangen.

    Einstellungen der Installationsparameter der Client-Anwendung des NCC

  9. Nach der Beendigung der Installation klicken Sie auf die Schaltfläche Schließen.

Dadurch wird die Client-Anwendung von NCC auf dem Computer installiert. Installieren Sie die Client-Anwendungen von NCC auf die Arbeitsplätze aller Administratoren Ihres Netzwerks in Übereinstimmung mit dem ausgewählten Bereitstellungsschema der Komponenten von der ViPNet Administrator Software. Danach können Sie KCA installieren.


Installation von ViPNet Key and Certification Authority

Nach der Installation von Server- und Client-Anwendungen von NCC können Sie mit der Installation von KCA anfangen.

Vor dem Installationsbeginn:

  • Überprüfen Sie, dass auf dem Computer standardmäßige Regionale Einstellungen vorgenommen und Zeitzone, Datum sowie Uhrzeit korrekt eingestellt sind. Ansonsten sind Probleme mit Darstellung der Symbole möglich.
  • Überprüfen Sie, dass Sie über eine Installationsdatei von ViPNet Key and Certification Authority verfügen.

Hinweis. Alle Informationen über die Lizenzbeschränkungen geht beim Herstellen der Verbindung mit der SQL-Datenbank ein, die bei der Installation der Server-Anwendung von NCC erstellt war.

Zur Installation des Programms gehen Sie wie folgt vor:

  1. Starten Sie die Installationsdatei [image] aus dem Ordner des Installationssatzes von ViPNet Network Control Center mit doppeltem Klicken.
  2. Warten Sie, bis die notwendige Software, einschließlich ViPNet CSP, auf dem Computer automatisch installiert worden ist.
  3. Nehmen Sie Einsicht in die Bedingungen dieser Lizenzvereinbarung im Fenster Installation von ViPNet Administrator [Key and Certification Authority] auf der Seite Lizenzvereinbarung. Beim Einverständnis aktivieren Sie entsprechendes Kontrollkästchen. Klicken Sie anschließend auf Weiter.
  4. Klicken Sie auf die Schaltfläche Einstellen auf der Seite Installationsart und geben Sie das Folgende an, falls Sie die Installationsparameter einstellen möchten:
    • Pfad zum Installationsordner des Programms auf dem Computer.
    • Benutzername und Name der Firma.
    • Name des Programmordners und sein Standort im Menü Start.
  5. Klicken Sie auf die Schaltfläche Jetzt installieren, um mit der Installation anzufangen.
  6. Nach der Beendigung der Installation klicken Sie auf die Schaltfläche Schließen.
  7. Falls nach der Installation ein Neustart des Computers erforderlich ist, zeigt das Programm eine entsprechende Meldung an. Starten Sie den Computer neu.

    Danach können sie mit der Arbeit mit der ViPNet Administrator Software anfangen.


Installation von Updates für die Software der Dritten

Die Software der Dritten, die zum Betrieb von ViPNet Network Control Center notwendig ist, kann Sicherheitslücken haben. Um den Einfluss der möglichen Sicherheitslücken auf den Betrieb des Programms zu vermeiden, sind die durch die Softwarehersteller ausgestellten Sicherheitsupdates rechtzeitig zu installieren.

Führen Sie folgende Aktionen nach der Installation der Server- und Client-Anwendungen von ViPNet Network Control Center aus:

  1. Prüfen Sie die Verfügbarkeit der Sicherheitsupdates und der neuen Versionen der Software der Dritten:
    • Microsoft .NET Framework Version 4.5.
    • Visual C++ 2010 Redistributable Package.
    • Verwendete Version von Microsoft SQL Server.
  2. Installieren Sie die Updates, falls diese verfügbar sind.
  3. Installieren Sie beim Betrieb von ViPNet Network Control Center regelmäßig die ausgestellten Updates der Software der Dritten.


Arbeitsbeginn

In diesem Abschnitt:

Erststart von ViPNet Network Control Center

Erststart von ViPNet Key and Certification Authority


Erststart von ViPNet Network Control Center

Nach der Installation der Komponenten von ViPNet Administrator Software überprüfen Sie, dass Sie über eine Lizenzdatei für das ViPNet Netzwerk *.itcslic bzw. infotecs.reg verfügen, und starten Sie ViPNet Network Control Center. Die Server-Anwendung von NCC besteht aus den Diensten NccService und NccFilewatcherService, die nach dem Start des Betriebssystems automatisch gestartet werden. Gehen Sie wie folgt vor, um die Client-Anwendung von NCC zu starten:

  1. Führen Sie eine der folgenden Aktionen:
    • Falls Sie das Betriebssystem Windows 7 oder Windows Server 2008 R2 betrieben, wählen Sie im Menü Start den Punkt Alle Programme > ViPNet > ViPNet Administrator > Network Control Center aus.
    • Falls Sie das Betriebssystem Windows 8 oder Windows Server 2012, öffnen Sie die Liste von Anwendungen auf dem Startbildschirm und wählen Sie ViPNet > Network Control Center aus

    Hinweis. Während der Installation konnte die Position des Programms im Menü Start oder in der Liste der Anwendungen geändert werden.

  2. aus. Beim Starten stellt die Client-Anwendung eine Verbindung mit der Server-Anwendung automatisch her. Standardmäßig wird die Verbindung an die Adresse des lokalen Computers hergestellt.

    Falls die Client. und die Server-Anwendung auf verschiedenen Computern installiert worden sind, wird eine Meldung über Fehlen der Verbindung mit dem Server angezeigt. Die gleiche Meldung wird dann angezeigt, wenn die Dienste der Server-Anwendung nicht gestartet sind.

    Meldung beim Fehlen der Verbindung mit dem SQL-Server

    In diesem Fall geben Sie im Meldefenster die IP-Adresse bzw. den DNS-Namen des Computers ein, auf dem die Server-Anwendung von ViPNet Network Control Center installiert ist, und klicken Sie auf die Schaltfläche Weiter.

  3. Geben Sie die Kontodaten des Administrators im Anmeldefsenster von ViPNet Network Control Center ein:
    • Benutzername: Administrator.
    • Passwort: Administrator.

    Eingabe der Anmeldedaten des Administrators

    Nach der Eingabe dieser Daten klicken Sie auf die Schaltfläche Weiter.

  4. Bei Erstanmeldung ??? ?????? ????? ? in ViPNet Network Control Center ist es zu Sicherheitszwecken erforderlich, das Passwort zu ändern. Geben Sie im Fenster Passwort ändern aktuell gültiges Passwort ein, danach geben Sie neues Passwort ein und bestätigen Sie die dieses.

    Das Passwort muss wenigstens acht Zeichen enthalten.

    Tipp. Es ist empfohlen, sicherere Passwörter festzulegen, die wenigstens acht Zeichen enthalten, einschließlich Groß- und Kleinbuchstaben, Ziffern und Spezialzeichen.

    Ändern des Passworts des Administrators von ViPNet Network Control Center

  5. Geben Sie im Fenster Arbeit mit ViPNet Network Control Center beginnen mit Hilfe der Schaltfläche Durchsuchen den Pfad zur Lizenzdatei für das ViPNet Netzwerk *.itcslic bzw. infotecs.reg ein und klicken Sie auf Weiter.

    Angabe des Pfades zur Lizenzdatei

  6. Wählen Sie im angezeigten Fenster ein der möglichen Arbeitsszenarien des Programms aus:
    • Wählen Sie zum automatischen Gestalten der Netzwerkstruktur und zum Vornehmen von Haupteinstellungen der Coordinatoren und Clients Struktur des privaten Netzwerks automatisch generieren mit Hilfe des Assistenten aus, falls das ViPNet Netzwerk neu erstellt wird.
    • Führen Sie Import und Upgrade der Datenbank von NCC 3.2.? aus, falls das ViPNet Netzwerk bereits bereitgestellt ist und bei der Arbeit mit NCC 4.? die in NCC 3.2.? erstellten Daten zu verwenden sind. Dazu wählen Sie Struktur des bestehenden Netzwerks laden aus. Für ausführliche Informationen zum Upgrade siehe Dokument „ViPNet Administrator. Handbuch zum Update von der Version 3.2.x auf die Version 4.?“, Abschnitt „Upgrade der Daten von Network Control Center 3.2.?“.
    • Wählen Sie zum automatischen Gestalten der Netzwerkstruktur und zum Vornehmen von Haupteinstellungen der Coordinatoren und Clients Struktur des privaten Netzwerks selbständig konfigurieren, falls das ViPNet Netzwerk neu erstellt wird.

      Auswahl der Aktion zum Arbeitsbeginn mit ViPNet Network Control Center

  7. Beim Erstellen eines neuen Netzwerks sieht Ihre Lizenz für das ViPNet Netzwerk die Einrichtung von Netzwerkhierarchie voraus; es wird eine Meldung mit einer Option angezeigt, Lizenzeinschränkungen zwischen den Netzwerken zu verteilen.

    Fenster mit einer Anfrage zur Lizenzverteilung

    Siehe Informationen über die Lizenzverteilung im Dokument „ViPNet Network Control Center. Administratorhandbuch“.

  8. Fangen Sie mit dem Betrieb des Programms je nach ausgewähltem Szenario an. Für ausführliche Informationen siehe Dokument „ViPNet Network Control Center. Administratorhandbuch“.
  9. Bei Bedarf erstellen Sie zusätzliche Benutzerkonten zur Arbeit in Network Control Center.

In diesem Abschnitt:

Erstellung von zusätzlichen Administratoren-Benutzerkonten von NCC


Erstellung von zusätzlichen Administratoren-Benutzerkonten von NCC

Falls in Ihrem Netzwerk mehrere Administratoren von NCC arbeiten werden, erstellen Sie für jeden Administrator ein neues Benutzerkonto nach dem Erststart der Client-Anwendung von NCC. Dies ermöglicht Logging und Monitoring aller Aktionen von jedem Administrator. Alle Administratoren sollen bei der Authentifizierung in allen Client-Anwendungen von NCC nur eigene Kontoangaben benutzen. Zum Erstellen eines Administrator-Benutzerkontos:

  1. Klicken Sie in der Anzeige Verwalten im Abschnitt Benutzerkonten auf der Ansichtsleiste die Schaltfläche icon ???????? ????.
  2. Geben Sie die Parameter des neuen Benutzerkontos im Fenster Neues Benutzerkonto ein und klicken Sie auf die Schaltfläche Erstellen.

    Erstellung des neuen Administrator-Benutzerkontos

Der Administrator, für den das Benutzerkonto erstellt worden ist, kann dieses zum Anmelden bei NCC in jeder Client-Anwendung verwenden.


Erststart von ViPNet Key and Certification Authority

Nach der Installation von KCA führen Sie den Erststart des Programms aus. Dazu:

  1. Führen Sie eine der folgenden Aktionen:
    • Falls Sie das Betriebssystem Windows 7 oder Windows Server 2008 R2 betrieben, wählen Sie im Menü Start den Punkt Alle Programme > ViPNet > ViPNet Administrator > Key and Certification Authority aus.
    • Falls Sie das Betriebssystem Windows 8 oder Windows Server 2012, öffnen Sie die Liste von Anwendungen auf dem Startbildschirm und wählen Sie ViPNet > Key and Certification Authority aus

    Hinweis. Während der Installation konnte die Position des Programms im Menü Start oder in der Liste der Anwendungen geändert werden.

  2. aus. Wählen Sie im Fenster Erste Schritte im Programm ViPNet Key and Certification Authority ein der möglichen Arbeitsszenarien des Programms aus:
    • Setzen Sie das Schaltfeld auf Konfiguration der neuen Datenbank und klicken Sie auf Weiter, falls das ViPNet Netzwerk neu erstellt wird und in KCA neue Daten zu erstellen sind. Es wird der Assistent zur primären Initialisierung gestartet. Führen Sie die primäre Initialisierung des Programms aus.

      Auswahl der Aktion zum Arbeitsbeginn mit ViPNet Key and Certification Authority

    • Führen Sie Import und Upgrade der Datenbank von KCA 3.2.x aus, falls das ViPNet Netzwerk bereits bereitgestellt ist und bei der Arbeit mit KCA 4.x die in KCA 3.2.x erstellten Daten zu verwenden sind. Dazu setzen Sie das Schaltfeld auf Import der Datenbank von Key and Certification Authority Version 3.x.x und klicken Sie auf Weiter, es wird das Programm zum Upgrade der Daten gestartet. Für ausführliche Informationen zum Upgrade siehe Dokument „ViPNet Administrator. Handbuch zum Update von der Version 3.2.x auf die Version 4.x“, Abschnitt „Upgrade der Daten von Key and Certification Authority 3.2.x“.

In diesem Abschnitt:

Primäre Initialisierung von ViPNet Key and Certification Authority


Primäre Initialisierung von ViPNet Key and Certification Authority

Falls beim Erststart von ViPNet Key and Certification Authority im Fenster Erste Schritte im Programm ViPNet Key and Certification Authority das Schaltfeld auf Konfiguration der neuen Datenbank gesetzt wurde, wird der Assistent zur primären Initialisierung gestartet.

Führen Sie folgende Aktionen aus, um die primäre Initialisierung von Key and Certification Authority durchzuführen:

  1. Klicken Sie auf die Schaltfläche Weiter > auf der ersten Seite des Assistenten zur primären Initialisierung.
  2. Geben Sie auf der Seite Verbinden zur Datenbak von ViPNet Administrator die Netzwerkadresse des Exemplars des SQL-Servers und den Datenbanknamen ein.

    Falls KCA und der SQL-Server auf demselben Computer wie die Server-Anwendung von NCC installiert worden sind, ist die Adresse des SQL-Servers .\winnccsql. Falls KCA auf einem anderen Computer installiert ist, geben Sie statt dem Punkt die IP-Adresse bzw. den DNS-Namen des Computers ein, auf dem der SQL-Server installiert ist, z.B. 192.168.32.152\winnccsql.

    Hinweis. Bei der Installation der Server-Anwendung von NCC konnte der Name des Exemplars des SQL-Servers geändert werden. In diesem Fall geben Sie den vorgegebenen Namen statt WINNCCSQL.

    Standardmäßiger Datenbankname ist ViPNetAdministrator.

    Eingabe der Parameter zum Anschluss an die SQL-Datenbank

    Achtung! Bei der primären Initialisierung sollte der Datenbankname nicht geändert werden, ansonsten wird weiterer Initialisierungsvorgang unmöglich.

  3. Wählen Sie den Authentifizierungsmodus beim Herstellen der Verbindung zum SQL-Server aus und klicken Sie auf Weiter >.

    Standardmäßig ist der Modus Mit Hilfe vom Namen und Passwort des Benutzers des SQL Servers ausgewählt und der Benutzername, unter dessen Benutzerkonto die Verbindung zum SQL-Server erfolgt, sowie das Passwort angegeben. Dieses Benutzerkonto wird bei der Installation der Server-Anwendung von NCC erstellt. Es wird nicht empfohlen, seine Parameter zu ändern (Name: KcaUser, Passwort: Number1).

    Auswahl des Authentifizierungstyps beim Anschließen an den SQL-Server

    Danach klicken Sie auf Weiter. Es wird eine Verbindung mit dem SQL-Server hergestellt. Falls die Verbindung nicht hergestellt werden kann, überprüfen Sie, dass alle früher angegebenen Parameter korrekt sind.

  4. Geben Sie auf der Seite Erstellung des ViPNet Netzwerkadministrators den Namen des Benutzerkontos des KCA-Administrators an, mit dem Sie im Programm arbeiten werden.
  5. Geben Sie die Informationen ein, die zum Ausstellen des Administrator-Stammzertifikats notwendig sind, falls in Ihrer Lizenz die Certification Authority-Funktionalität verfügbar ist. Ansonsten führen Sie Schritt 11 aus.
  6. Geben Sie auf den ersten Seiten des Assistenten Information über Zertifikatantragsteller den Administratornamen und andere notwendige Informationen an, die anschließend ins Zertifikat hinzuzufügen sind, und klicken Sie auf die Schaltfläche Weiter.

    Angabe der Informationen über den Besitzer des angefragten Zertifikats

  7. Bei Bedarf bearbeiten Sie auf der Seite Zusätzliche Informationen über den Zertifikatsbesitzer die zusätzlichen Angaben des Besitzers. Dazu wählen Sie in der Liste entsprechende Attribute aus, klicken Sie auf die Schaltfläche Ändern und geben Sie die notwendige Informationen an. Klicken Sie anschließend auf die Schaltfläche Weiter.

    Zusätzliche Informationen über den Zertifikatsbesitzer

  8. Wählen Sie auf der Seite Parameter des privaten Schlüssels den Cryptoprovider in Übereinstimmung mit der unten angegebenen Tabelle oder einen anderen auf dem Computer installierten Cryptoprovider aus. Der ausgewählte Cryptoprovider bestimmt den Signaturalgorithmus, nach dem der private Schlüssel sowie der öffentliche Schlüssel zu erstellen sind und die Hash-Funktion zu berechnen ist.

    Außerdem geben Sie die Parameter des Signaturalgorithmus an. In Übereinstimmung mit den angegebenen Parametern werden die Länge des öffentlichen Schlüssels und der Hashing-Algorithmus automatisch bestimmt.

    Tipp. Es wird empfohlen, die Algorithmus-Standardparameter zu verwenden. Diese Parameter zeichnen sich durch eine höhere Geschwindigkeit bei der Berechnung und Prüfung der Signatur aus.

    Einstellung der Parameter des privaten Schlüssels

  9. Geben Sie auf der Seite Gültigkeitsdauer des Zertifikats die Gültigkeitsdauer des Zertifikats auf beliebige Weise.

    Eingabe der Gültigkeitsdauer des Zertifikats

  10. Falls es erforderlich ist, in KCA qualifizierte Zertifikate (Betrieb im Modus der akkreditierten Zertifizierungsstelle) auszustellen, aktivieren Sie das Kontrollkästchen Betrieb im Modus einer akkreditierten Zertifizierungsstelle auf der Seite Software Tools und geben Sie mit Hilfe der Schaltfläche Einstellen die Werkzeuge an, die durch Ihre Zertifizierungsstelle verwendet werden. Für ausführliche Informationen zum Betrieb im Modus der akkreditierten Zertifizierungsstelle siehe Dokument „ViPNet Key and Certification Authority. Administratorhandbuch“, Kapitel „Verwaltung der Zertifikate“, Abschnitt „Ausstellung der qualifizierten Zertifikate“.

    Einstellungen für akkreditierte Zertifizierungstelle

    Bei Bedarf können Sie auf dieser Seite zusätzlich auch die Informationen über digitale Signaturwerkzeuge der Zertifikatsbesitzer (Benutzer) angeben.

    Hinweis. Sie können das Kontrollkästchen aktivieren und alle notwendigen Angaben über die verwendeten Werkzeuge auch nach der primären Initialisierung in den Programmeinstellungen angeben, aber dabei ist es zu berücksichtigen, dass ein früher für Sie ausgestelltes Zertifikat des öffentlichen Schlüssels mit dem Format des qualifizierten Zertifikats nicht übereinstimmen wird.

  11. Führen Sie eine der folgenden Aktionen auf der Seite Automatischer Arbeitsmodus aus:
    • Ändern Sie die Inaktivitätszeit des Administrators, nach Ablauf von welcher KCA zum automatischen Arbeitsmodus wechseln wird (standardmäßig beträgt sie 15 Minuten).
    • Deaktivieren Sie entsprechendes Kontrollkästchen, damit KCA zum automatischen Arbeitsmodus nicht wechselt, falls der Administrator keine Aktionen vornimmt.

    Für ausführliche Informationen zum Betrieb von KCA im automatischen Modus siehe Dokument „ViPNet Key and Certification Authority. Administratorhandbuch“, Abschnitt „Arbeitsmodi in ViPNet Key and Certification Authority“.

    Einstellung der Parameter für den automatischen Modus

    Hinweis. Sie können die Parameter des automatischen Arbeitsmodus von KCA auch nach der primären Initialisierung in den Einstellungen des Programms einstellen.

  12. Stellen Sie die Vorgänge ein, die im automatischen Modus von KCA ausgeführt werden sollen, Falls Sie im vorherigen Schritt den Wechsel von KCA zum automatischen Arbeitsmodus bei der Inaktivität des Administrators ausgewählt haben. Dazu wählen Sie den Vorgang aus, klicken Sie auf Einstellen und aktivieren Sie entsprechendes Kontrollkästchen im angezeigten Fenster. Geben Sie für die Vorgänge von Erstellung der Netzwerkknotenschlüssel, Laden der Zertifikatsperrlisten der ViPNet Partnernetzwerke und Aktualisierung der Zertifikatsperrlisten an, wenn der Vorgang auszuführen ist.

    Auswahl der Operationen zum Ausüben im automatischen Modus

    Hinweis. Falls Sie keine Lizenz zum Betrieb von KCA als Zertifizierungsstelle (für ausführliche Informationen siehe Dokument „ViPNet Key and Certification Authority. Administratorhandbuch“, Kapitel „Allgemeine Informationen“) haben, können Sie zur Ausführung des Programms im automatischen Modus nur die Erstellung der Netzwerkknotenschlüssel und Akzeptierung der Anfragen auf Schlüsseldistributionen auswählen.
  13. Wählen Sie auf der Seite Speicherort für Container der Signaturschlüssel und Schutzschlüssel der Zertifizierungsstelle den Speicherort des Schlüsselcontainers des Administrators aus: Datei oder Externes Gerät. Falls die Speicherung des Schlüssels auf einem externen Gerät ausgewählt worden ist, wählen Sie weiter ein externes Datenspeichergerät aus, nachdem Sie dieses angeschlossen haben und den Treiber installiert haben. Bei Bedarf geben Sie einen PIN-Code des externen Geräts ein.

    Je nach ausgewählten Speicherort wird die Gültigkeitsdauer des privaten Schlüssels bestimmt. Beim Speichern des privaten Schlüssels in einer Datei auf dem Computer oder einem externen Gerät, das den Algorithmus GOST 34.10-2001 nicht unterstützt, beschränkt sich die Gültigkeitsdauer des Schlüssels auf ein Jahr. Falls der private Schlüssel auf einem Gerät mit Unterstützung von GOST 34.10-2001 gespeichert wird (unmittelbar auf dem Gerät erstellt wurde), beträgt seine Gültigkeitsdauer 3 Jahre.

    Nach Ablauf der Gültigkeitsdauer sollte planmäßiger Ersatz des privaten Schlüssels durchgeführt werden. Unter dieser Gültigkeitsdauer wird die Benutzungsdauer des privaten Schlüssels zum Signieren von den ausgestellten Benutzerzertifikate verstanden. Die Gültigkeitsdauer des privaten Schlüssels gilt für die Signatur der Zertifikatsperrliste nicht. Nach Ablauf der Gültigkeitsdauer des privaten Schlüssels kann er zum Signieren der Zertifikatsperrliste verwendet werden.

    Der Speicherort des privaten Schlüssels und seine Gültigkeitsdauer müssen im Arbeitsverfahren Arbeit der Zertifizierungsstelle erfasst werden.

  14. Geben Sie folgende Parameter auf der Seite Paswörter einstellen an:
    • Passwort-Typ:
      • Benutzerdefiniertes Passwort für das Passwort, das vom Administrator definiert wird.
      • Zufälliges Passwort für ein Passwort, das auf der Grundlage der Passwortphrase automatisch generiert wird.
      • Zufälliges numerisches Passwort für ein Passwort, das aus vorgegebener Anzahl von Ziffern automatisch generiert wird.

    Hinweis. Der angegebene Passworttyp wird in den Programmeinstellungen gespeichert und beim Erstellen anderer Passwörter berücksichtigt. Ändern Sie entsprechende Einstellungen, wenn Sie möchten, dass die Passwörter eines anderen Typs erstellt werden.

    • Ausstellungsverfahren der Benutzerpasswörter in ViPNet:
      • Passwort in die Datei speichern, um die Passwörter in den Dateien auszustellen. Geben Sie den Ordner an, wo die Dateien mit den Passwörtern zu speichern sind.
      • Passwort drucken, um ausgedruckte Passwörter auszustellen. Wählen Sie den Drucker in der Druckerliste aus, der zum Drucken zu verwenden ist.

    Auswahl des Typs des Administrator-Passworts

  15. Geben Sie das Administratorpasswort und eine Bestätigung auf der angezeigten Seite ein, falls der Typ Benutzerdefiniertes Passwort ausgewählt worden ist. Das Passwort muss wenigstens acht Zeichen enthalten.

    Achtung! Es ist empfohlen, sicherere Passwörter festzulegen, die wenigstens acht Zeichen enthalten, einschließlich Groß- und Kleinbuchstaben, Ziffern und Spezialzeichen.

    Erstellen Sie die Passwörter aus 32 Zeichen nicht. Später ist es unmöglich, mit Passwort solcher Länge Authentifizierung durchzuführen. Diese Beschränkung ist mit dem bestehenden Übergabealgorithmus des Passworts in den Cryptoprovider verbunden. In Übereinstimmung mit diesem Algorithmus darf die Passwortlänge 31 Zeichen nicht überschreiten.

    Falls ein Typ der zufälligen Passwörter ausgewählt worden ist, führen Sie den Kursor innerhalb des Fensters beim Anzeigen des biometrischen Generators und merken Sie sich Ihr neues Passwort (oder die Passwortphrase).

    Bei Bedarf ändern Sie die Parameter des zufälligen Passworts und erzeugen Sie ein anderes Passwort.

  16. Überprüfen Sie auf der Seite der Bereitschaft zum Beenden der primären Initialisierung von KCA, dass alle Parameter, die auf früheren Seiten des Assistenten angegeben wurden, korrekt sind. Klicken Sie auf die Schaltfläche Drucken, um diese Parameter auszudrucken. Falls es erforderlich ist, die Parameter zu ändern, wechseln Sie zur notwendigen Seite mit Hilfe der Schaltfläche Zurück.

    Klicken Sie auf Weiter, um fortzufahren Es wird biometrischer Generator angezeigt, falls er bei der primären Initialisierung nicht gestartet wurde. Führen Sie den Cursor innerhalb des Fensters Biometrischer Generator.

  17. Bei erfolgreichem Beenden der Initialisierung wird auf der letzten Seite des Assistenten eine entsprechende Meldung angezeigt und neben jedem der ausgeführten Vorgänge ein Zeichen ICO V dargestellt. Falls einige Vorgänge bei der Initialisierung mit Fehlern abgeschlossen werden, werden diese mit Zeichen ICO x markiert.

    Überprüfen Sie, dass die primäre Initialisierung erfolgreich abgeschlossen ist, und danach klicken Sie auf Schließen.

    Beendigung der primären Initialisierung

Bei erfolgreicher primären Initialisierung werden folgende Vorgänge durchgeführt:

  • Erstellung des Benutzerkontos des KCA-Administrators.
  • Erstellung des privaten Schlüssels und Ausstellung des Administratorzertifikats von KCA (soweit die Benutzung von der Funktionalität der Zertifizierungsstelle erlaubt ist).

    Hinweis. Das Zertifikat, das für neuen Administrator erstellt wird, ist selbstsigniert. Falls KCA als eine untergeordnete Zertifizierungsstelle agiert und nach dem Verfahren solches Zertifikat zum Signieren der ausgestellten Benutzerzertifikate nicht verwendet werden darf, erhalten Sie ein anderes Zertifikat in einer übergeordneten Zertifizierungsstelle auf Sonderanfrage (siehe Dokument „ViPNet Key and Certification Authority. Administratorhandbuch“, Abschnitt „Aufbau der Partnerverhältnisse auf der Grundlage des hierarchischen Modells“).

    Außerdem, falls Sie die Arbeitsparameter von KCA als akkreditierte Zertifizierungsstelle vorgegeben haben, wird das ausgestellte Zertifikat mit dem Format des qualifizierten Zertifikats übereinstimmen.

  • Erstellung von Masterschlüsseln.
  • Herstellung der Verbindung mit der SQL-Datenbank und Füllung der Datenbank mit den Daten.

Bei korrekter Initialisierung wird das Hauptfenster des Programms angezeigt. Nun können Sie mit der Arbeit mit KCA anfangen.

Im Falle der inkorrekten Initialisierung stellen Sie die Fehlerursache fest, installieren Sie KCA erneut, nachdem Sie aktuelle Version des Programms deinstallieren, und wiederholen Sie die primäre Initialisierung.


Update der ViPNet Administrator Software

In diesem Abschnitt:

Vorgehensweise beim Update von Komponenten der ViPNet Administrator Software

Update der Anwendungen von ViPNet Network Control Center

Update von ViPNet Key and Certification Authority


Vorgehensweise beim Update von Komponenten der ViPNet Administrator Software

Achtung! Aktualisieren Sie nach Erhalten der Updates für ViPNet Administrator sowohl die Anwendungen von ViPNet Network Control Center als auch das Programm ViPNet Key and Certification Authority. Die Programme ViPNet Network Control Center und ViPNet Key and Certification Authority verschiedener Versionen können miteinander inkompatibel sein.

Es wird empfohlen, die Komponenten der ViPNet Administrator Software wie folgt zu aktualisieren:

  1. Aktualisieren Sie die Server-Anwendung von ViPNet Network Control Center.
  2. Aktualisieren Sie die Client-Anwendung von ViPNet Network Control Center.
  3. Aktualisieren Sie ViPNet Key and Certification Authority.

Überprüfen Sie vor dem Beginn der Aktualisierung von den Komponenten von ViPNet Administrator, dass Ihre Lizenz die Verwendung der neuen Version erlaubt. Dazu wählen Sie in ViPNet Network Control Center im Menü Lizenz den Punkt Informationen zu Lizenz des eigenen Netzwerks aus. Im angezeigten Fenster in der Registerkarte Allgemeine Informationen sind die Angaben über die maximale Version von ViPNet Administrator dargestellt.

Außerdem wird es empfohlen, vor dem Aktualisieren eine Sicherheitskopie der Netzwerkkonfiguration mit Hilfe von ViPNet Key and Certification Authority zu erstellen, die beim Auftreten der Probleme nach der Aktualisierung hilft, die Daten wiederherzustellen. Ausführliche Informationen zum Erstellen und Wiederherstellen der Sicherungskopien ist im Dokument „ViPNet Key and Certification Authority. Administratorhandbuch“, Abschnitt „Administrative Funktionen“ enthalten.


Update der Anwendungen von ViPNet Network Control Center

Das Update von Server- und Client-Anwendung von NCC hat einen Unterschied, der darin besteht, dass beim Update der Server-Anwendung die Verbindungsparameter mit der Datenbank einzugeben sind. Das ist damit verbunden, dass zusammen mit der Server-Anwendung auch die Datenbank aktualisiert wird, in der die Konfigurationsangaben des ViPNet Netzwerks und Einstellungsangaben von ViPNet Network Control Center und ViPNet Key and Certification Authority gespeichert werden.

Achtung! Vor dem Update der Server-Anwendung von NCC muss der Betrieb von KCA beendet werden.

Gehen Sie wie folgt vor, um eine der Anwendungen zu aktualisieren:

  1. Starten Sie mit Doppelklick die Datei [image] aus dem Installationssatz der neuen Version der Anwendung.
  2. Wählen Sie die Sprache für das Programm ViPNet Network Control Center im angezeigten Fenster aus und klicken Sie auf Weiter.
  3. Wählen Sie Aktualisieren auf der Seite Komponenten hinzufügen oder deinstallieren aus und klicken Sie auf die Schaltfläche Weiter.

    Änderungsseite der installierten Komponenten

  4. Geben Sie die Datenbank-Verbindungsparameter auf der Seite Software aktualisieren an. Diese Seite wird nur beim Updaten der Server-Anwendung angezeigt.

    Klicken Sie auf der Schaltfläche Verbindung überprüfen, um die Verbindung mit dem SQL-Server zu überprüfen. Nach erfolgreicher Verbindungsprüfung klicken Sie auf die Schaltfläche Aktualisieren, um fortzufahren. Im Gegenfall geben Sie korrekte Datenbank-Verbindungsparameter an.

    Einstellungsseite der Parameter zum Anschluss an die Datenbank

  5. Warten Sie, bis die Aktualisierung beendigt wird.

Nach dem Aktualisieren der Server- und Client-Anwendungen aktualisieren Sie KCA.


Update von ViPNet Key and Certification Authority

Für das Update von ViPNet Key and Certification Authority:

  1. Starten Sie mit Doppelklick die Datei [image] aus dem Installationssatz der neuen Version des Programms auf dem Computer mit ViPNet Key and Certification Authority.
  2. Klicken Sie auf die Schaltfläche Update beginnen auf der Seite Update des Installationsassistenten von ViPNet Key and Certification Authority.

    Seite „Update“ des Installationsassistenten von ViPNet Key and Certification Authority

  3. Warten Sie, bis die Aktualisierung beendigt wird, und klicken Sie auf die Schaltfläche Schließen.
  4. Nach Beendigung der Installation kann ein Fenster mit der Option, den Computer neu zu starten, angezeigt werden. In diesem Fall führen Sie den Neustart des Computers aus.

Nun können Sie mit dem Administrieren des Netzwerks unter Verwendung des aktualisierten Programms anfangen.


Deinstallieren der ViPNet Administrator Software

In diesem Abschnitt:

Wann die Komponenten der ViPNet Administrator Software deinstalliert werden sollen?

Deinstallieren der Anwendungen von ViPNet Network Control Center

Deinstallation von ViPNet Key and Certification Authority


Wann die Komponenten der ViPNet Administrator Software deinstalliert werden sollen?

Das Deinstallieren von den Komponenten von ViPNet Administrator Software ist nach erfolgreichem Migrieren der Software auf einen neuen Computer erforderlich (siehe ausführliche Informationen in „ViPNet Administrator. Handbuch zum Migrieren der Software auf einen anderen Computer“). Bei Bedarf können Sie das Deinstallationsszenario auch bei einem inkorrekten Update der Softwarekomponenten verwenden.

Im ersten Fall muss zusammen mit den Softwarekomponenten auch die Datenbank von ViPNet Administrator und alle Benutzerdaten gelöscht werden. Im zweiten Fall erfolgt die Löschung der Datenbank und der Benutzerdaten nach Ermessen des Administrators.

Sie können die Datenbank von ViPNet Administrator beim Deinstallieren der Server-Anwendung von NCC löschen, falls Sie entsprechendes Kontrollkästchen aktivieren. Sie können die Benutzerdaten beim Deinstallieren jeder Komponente von ViPNet Administrator auch nach Aktivieren der entsprechenden Kontrollkästchen löschen (siehe Deinstallationsszenarien unten).


Deinstallieren der Anwendungen von ViPNet Network Control Center

In aktueller Version des Programms ist das Deinstallieren der Server- und Client-Anwendung von ViPNet Network Control Center nur mit Hilfe der Werkzeuge des Betriebssystems möglich.

Gehen Sie wie folgt vor, um eine der Anwendungen von NCC zu deinstallieren:

  1. Wählen Sie den Punkt Systemsteuerung im Menü Start aus.
  2. Wählen Sie die Kategorie Programme auf der Seite Einstellungen des Computers anpassen aus.
  3. Wählen Sie die notwendige Anwendung in der Liste auf der Seite Programm deinstallieren oder ändern aus und klicken Sie auf die Schaltfläche Deinstallieren.
  4. Wählen Sie im angezeigten Fenster auf der Seite Komponenten hinzufügen oder entfernen den Punkt Alle Komponenten entfernen aus und klicken Sie auf Weiter.
  5. Aktivieren Sie entsprechendes Kontrollkästchen auf der Seite Deinstallation des Produkts zum Löschen der Benutzerangaben. Falls dieses Kontrollkästchen bei der Deinstallation der Server-Anwendung aktiviert ist, wird zusammen mit den Benutzerangaben die Datenbank von ViPNet Administrator gelöscht. Bei Bedarf können Sie die Verbindung mit der Datenbank vor dem Löschen prüfen.
  6. Klicken Sie auf die Schaltfläche Deinstallieren.
  7. Warten Sie, bis die Deinstallation der Anwendung beendigt wird, und klicken Sie auf die Schaltfläche Schließen.


Deinstallation von ViPNet Key and Certification Authority

Zur Deinstallation von ViPNet Key and Certification Authority:

  1. Führen Sie eine der folgenden Aktionen durch:
    • Falls Sie das Betriebssystem Windows 7 oder Windows Server 2008 R2 betrieben, wählen Sie im Menü Start den Punkt Alle Programme > ViPNet > ViPNet Administrator > Installation von ViPNet Key and Certification Authority aus.
    • Falls Sie das Betriebssystem Windows 8 oder Windows Server 2012, öffnen Sie die Liste von Anwendungen auf dem Startbildschirm und wählen Sie ViPNet > Installation von ViPNet Key and Certification Authority aus.

    Hinweis. Während der Installation konnte die Position des Programms im Menü Start oder in der Liste der Anwendungen geändert werden.

  2. Wählen Sie auf der Seite Komponenten hinzufügen oder entfernen den Punkt Alle Komponenten entfernen aus und klicken Sie auf Weiter.
  3. Aktivieren Sie das Kontrollkästchen Benutzerdaten löschen auf der Seite Produkt löschen, falls Sie die Dateien der KCA-Administratorschlüssel und andere Dienstdateien löschen möchten. Klicken Sie auf die Schaltfläche Deinstallieren.
  4. Warten Sie, bis die Deinstallation des Programms beendigt wird, und klicken Sie auf die Schaltfläche Schließen.


Mögliche Störungen

Bei der Installation und Aktualisierung der ViPNet Administrator Software können folgende Probleme auftreten:

  • Die Anwendungen der Dritten können nicht installiert werden.
  • Server- oder Client-Anwendung von NCC kann nicht installiert werden.
  • Client-Anwendung von NCC kann nicht gestartet werden.
  • Inkorrekte Initialisierung von KCA.
  • Nach der Aktualisierung kann NCC oder KCA nicht gestartet werden.
  • Inkorrekte Darstellung der Symbole in KCA.
  • KCA kann nicht gestartet werden.

In diesem Abschnitt:

Die Anwendungen der Dritten können nicht installiert werden

Server- oder Client-Anwendung von NCC kann nicht installiert werden

Client-Anwendung von NCC kann nicht gestartet werden

Inkorrekte Initialisierung von KCA

Nach der Aktualisierung kann NCC oder KCA nicht gestartet werden

Inkorrekte Darstellung der Symbole in KCA

KCA kann nicht gestartet werden


Die Anwendungen der Dritten können nicht installiert werden

Vielleicht ist der Speicherplatz auf der Festplatte des Computers nicht genug. Geben Sie den erforderlichen Speicherplatz frei und wiederholen Sie den Installationsversuch.


Server- oder Client-Anwendung von NCC kann nicht installiert werden

Mögliche Ursachen:

  • Aktuelle Updates für das Betriebssystem sind nicht installiert.
  • Die Parameter des ausgewählten Exemplars des SQL-Servers entsprechen den im Abschnitt Information für den SQL-Administrator angegebenen Parametern nicht. Wenden Sie sich an den Administrator des SQL-Servers.
  • Der Dienst NccService der Server-Anwendung des NCC kann nicht gestartet werden. Wenden Sie sich an den Administrator des SQL-Servers und überprüfen Sie die Parameter des ausgewählten Exemplars des SQL-Servers.

    Gehen Sie wie folgt vor, falls der Dienst immer noch nicht gestartet werden kann:

    • Installieren Sie die Umgebung SQL Server Management Studio 2014 auf den Computer mit SQL-Server, falls sie nicht vorhanden ist. Sie können diese auf der Webseite von Microsoft herunterladen.

      Achtung! Die Umgebung SQL Server Management Studio muss auf dem Computer nach dem Erstellen der Datenbankservers installiert werden, ansonsten ist die Installation der Server-Anwendung von NCC unmöglich.

    • Starten Sie die Umgebung SQL Server Management Studio mit Hilfe vom Menü Start.
    • Stellen Sie die Verbindung mit dem installierten SQL-Server her.
    • Öffnen Sie das Fenster mit den Eigenschaften des installierten SQL-Servers und nehmen Sie folgende Einstellungen vor:
      • stellen Sie den Wert Full access enabled für die Eigenschaft Filestream Access Level in der Registerkarte Advanced ein
      • stellen Sie den Wert SQL Server and Windows Authentication mode für die Eigenschaft Server authentication in der Registerkarte Security ein.
  • Der Computer, auf welchen Sie die Server-Anwendung von NCC und das Datenbankverwaltungssystem (DBVS) installieren, ist ein Domänencontroller. Aus Sicherheitsgründen empfiehlt Microsoft nicht, SQL-Server auf Domänencontroller zu installieren. Installieren Sie das DBVS auf einen Computer, der kein Domänencontroller ist.


Client-Anwendung von NCC kann nicht gestartet werden

Mögliche Ursachen:

  • Die Dienste der Server-Anwendung von NCC NccService und NccFilewatcherService konnten nach dem Start des Betriebssystems automatisch nicht gestartet werden. Starten Sie diese Dienste, wozu:
    • Starten Sie „Windows Task-Manager“ mit Hilfe der Tastenkombination Strg+Shift+Esc.
    • Wechseln Sie zur Registerkarte Dienste im Fenster Windows Task-Manager.
    • Finden Sie den Dienst NccService in der Liste, klicken Sie auf diesen Dienst mit rechter Maustaste und wählen Sie im Kontextmenü den Punkt Dienst starten aus.
    • Starten Sie den Dienst NccFilewatcherService auf dieselbe Weise.
  • Der Computer mit Server-Anwendung von NCC ist ausgeschaltet.
  • Keine Verbindung zwischen den Computern mit der Client- und Server-Anwendung von NCC. Zur Prüfung der Verbindung benutzen Sie den Befehl ping.
  • Auf dem Computer mit der Client- und Server-Anwendung von NCC ist eine Firewall gestartet, die die Verbindung blockiert (z.B. Windows-Firewall). Prüfen Sie die Einstellungen der Firewalls.
  • Ihr Computer ist an das Netzwerk nicht angeschlossen.


Inkorrekte Initialisierung von KCA

Mögliche Ursachen:

  • Inkorrekter Betrieb des biometrischen Generators.
  • Zufällige oder absichtliche Störung (Löschen) der Datenbank.
  • Vorgabe von inkorrekten Kontoangaben des SQL-Datenbankbenutzers. Das sind für KCA:
    • Benutzername: KcaUser.
    • Passwort: Number1.

Nachdem Sie die Fehlerursache festlegen, wiederholen Sie die primäre Initialisierung von ViPNet Key and Certification Authority. Löschen Sie den Ordner C:\ProgramData\Infotecs\ViPNet Administrator\KC mit allem Inhalt, falls beim Starten des Programms der Initialisierungsassistent automatisch nicht gestartet wird.


Nach der Aktualisierung kann NCC oder KCA nicht gestartet werden

Vielleicht sind nicht alle Komponenten der ViPNet Administrator Software aktualisiert. Überprüfen Sie, dass alle Anwendungen, die Teil der ViPNet Administrator Software sind, aktualisiert sind: Client- und Server-Anwendungen von NCC, KCA.


Inkorrekte Darstellung der Symbole in KCA

Vielleicht sind standardmäßige Regionaleinstellungen in Windows nicht vorgenommen. Öffnen Sie die Systemsteuerung und nehmen Sie notwendige Einstellungen vor.


KCA kann nicht gestartet werden

Folgende Ursachen sind möglich:

  • Der Computer mit Server-Anwendung von NCC und SQL-Datenbank ist ausgeschaltet.
  • Keine Verbindung zwischen den Computern mit Server-Anwendungen von NCC und KCA. Zur Prüfung der Verbindung benutzen Sie den Befehl ping.
  • Auf dem Computer mit KCA und Server-Anwendung von NCC ist eine Firewall gestartet, die die Verbindung blockiert (z.B. Windows-Firewall). Prüfen Sie die Einstellungen der Firewalls.
  • Ihr Computer ist an das Netzwerk nicht angeschlossen.


Regionaleinstellungen

Zur korrekten Darstellung des deutschen Interfaces von ViPNet Administrator im Betriebssystem Microsoft Windows mit englischer Lokalisierung sollte die Unterstützungsfunktion von Umlauten und „ß“ aktiviert werden. Das gilt besonders für Programme, die keinen Unicode-Standard unterstützen. Es wird empfohlen, diese Einstellung bereits vor der Programminstallation durchzuführen.

Diese Parameter sollten auch dann eingestellt werden, wenn ein deutsches MUI (Multilanguage User Interface) installiert wurde. Das bedeutet, dass der Kern des Betriebssystems Englisch ist und die deutsche Sprache für das Interface und die Help-Dateien später installiert wurde. In diesem Fall sind die Regionaleinstellungen Englisch und sollten geändert werden.

Achtung! Zum Ändern von Regionaleinstellungen sollten Sie über Administratorrechte im Betriebssystem verfügen.

In diesem Abschnitt:

Regionaleinstellungen für Windows 7, Server 2008 R2

Regionaleinstellungen für Windows 8, Server 2012, Windows 8.1, Server 2012 R2, Windows 10


Regionaleinstellungen für Windows 7, Server 2008 R2

Auf diese Weise erreichen Sie die korrekte Darstellung der Umlaute und „ß“ für Windows Vista/Server 2008/Windows 7:

  1. Wählen Sie Systemsteuerung im Menü Start > Systemsteuerung (Control Panel) > Zeit, Sprache und Region (Clock, Language, and Region) > Region und Sprache (Region and Language) aus.
  2. Klicken Sie auf die Registerkarte Verwaltung (Administrative) im Fenster Region und Sprache (Region and Language).

  3. Klicken Sie auf Gebietsschema ändern (Change system locale) in der Registerkarte Verwaltung (Administrative).
  4. Wählen Sie Deutsch (Deutschland) im neu geöffneten Fenster in der Liste Aktuelles Gebietsschema aus und klicken auf OK.

    Auswahl der Systemsprache

  5. Klicken Sie auf OK. Der Computer muss neu gestartet werden.
  6. Nach dem Neustart öffnen Sie Systemsteuerung (Control Panel) > Zeit, Sprache und Region (Clock, Language, and Region) > Region und Sprache (Region and Language).
  7. Klicken Sie auf die Registerkarte Verwaltung (Administrative) im Fenster Region und Sprache (Region and Language).
  8. Klicken Sie auf die Schaltfläche Einstellungen kopieren (Copy settings) in der Registerkarte Verwaltung (Administrative).
  9. Aktivieren Sie das Kontrollkästchen Willkommensseite und Benutzerkonten (Welcome screen and system accounts) im neu geöffneten Fenster und klicken auf OK.

    Kopieren der Parameter

Um weitere Probleme mit der Zeichencodierung auf einigen Systemen zu vermeiden, nehmen Sie die folgenden Einstellungen vor:

  1. Gehen Sie zur Registerkarte Formate (Formats) des Fensters Region und Sprache (Region and Language) und wählen Sie Deutsch (Deutschland) in der Liste Format aus.

    Einstellung von Formaten

  2. Gehen Sie zur Registerkarte Aufenthaltsort (Location) des Fensters Region und Sprache (Region and Language) und wählen Sie Deutschland in der Liste Aktueller Aufenthaltsort (Current location) aus.

    Auswahl des aktuellen Aufenthaltsortes


Regionaleinstellungen für Windows 8, Server 2012, Windows 8.1, Server 2012 R2, Windows 10

Auf diese Weise erreichen Sie die korrekte Darstellung der Umlaute und „ß“ für Windows 8, Windows 8.1, Server 2012, Server 2012 R2 und Windows 10:

  1. Wählen Sie Systemsteuerung im Menü Start > Systemsteuerung (Control Panel) > Region aus.
  2. Klicken Sie auf die Registerkarte Verwaltung (Administrative) im Fenster Region.

    ?????????????? ???????? ?????????

  3. Klicken Sie auf Gebietsschema ändern (Change system locale) in der Registerkarte Verwaltung (Administrative).
  4. Wählen Sie Deutsch (Deutschland) (German (Germany)) im neu geöffneten Fenster in der Liste aus.

    ????? ????? ???????

  5. Klicken Sie auf die Schaltfläche OK. Der Computer muss neu gestartet werden.
  6. Öffnen Sie Nach dem Neustart das Menü Systemsteuerung (Control Panel) > Region.
  7. Klicken Sie auf die Registerkarte Verwaltung (Administrative) im Fenster Region.
  8. Klicken Sie auf die Schaltfläche Einstellungen kopieren (Copy settings) in der Registerkarte Verwaltung (Administrative).
  9. Aktivieren Sie das Kontrollkästchen Willkommensseite und Benutzerkonten (Welcome screen and system accounts) im neu geöffneten Fenster und klicken Sie auf OK.

Um weitere Probleme mit der Zeichencodierung auf einigen Systemen zu vermeiden, nehmen Sie die folgenden Einstellungen vor:

  1. Gehen Sie zur Registerkarte Formate (Formats) des Fensters Region und wählen Sie Deutsch (Deutschland) in der Liste Format aus.

  2. Gehen Sie zur Registerkarte Aufenthaltsort (Location) des Fensters Region und wählen Sie Deutschland in der Liste Aktueller Aufenthaltsort (Current location) aus.

    ????? ???????? ????????????


Externe Datenträger

In diesem Abschnitt:

Allgemeine Informationen

Liste externer Datenträger


Allgemeine Informationen

Externe Geräte werden zum Speichern der Schlüsselcontainer verwendet. Diese Schlüsselcontainer können für die Authentifizierung, zum Erstellen von digitalen Signaturen oder für andere Zwecke verwendet werden.

Auf dem externen Gerät können Schlüssel gespeichert werden, die mit Hilfe unterschiedlicher Algorithmen in ViPNet Software oder in Drittanwendungen erstellt wurden. Die maximale Anzahl der Schlüsselcontainer, die auf einem externen Gerät gespeichert werden können, hängt von der Speicherkapazität des Geräts ab.

Alle Operationen mit Schlüsselcontainern und externen Geräten können Sie im Programm ViPNet CSP durchführen. Damit ein externes Gerät auf dem Computer verwendet werden kann, sollten zunächst die Treiber dieses Geräts installiert werden. Stellen Sie vor dem Speichern der Schlüssel auf dem Gerät sicher, dass das Gerät formatiert ist.


Liste externer Datenträger

In der nachfolgenden Tabelle sind externe Geräte aufgelistet, die in der ViPNet Software verwendet werden können. Für jedes externe Geräte werden die Beschreibung, die Bedingungen und Besonderheit der Verwendung sowie Informationen zur Unterstützung des Standards PKCS#11 aufgeführt.

Liste externer Datenträger

Name des Geräts in Software ViPNet CSP | Vollständiger Name und Gerätetyp | Anwendungsbedingungen | Unterstützung von PKCS#11
eToken Aladdin | Persönlicher elektronischer Schlüssel eToken PRO (Java), eToken PRO vom Hersteller Aladdin. | Auf dem Netzwerkknoten muss die Software PKI Client 5.1 oder höher installiert sein. eToken PRO SmartCard kann mit jedem PC/SC-kompatiblen Smart Card Reader benutzt werden. | Ja
Siemens CardOS | SmartCards CardOS/M4.01a, CardOS V4.3B, CardOS V4.2B, CardOS V4.2B DI, CardOS V4.2C, CardOS V4.4 vom Hersteller Atos (Siemens). | Auf dem Computer muss die Software Siemens CardOS API V5.0 oder höher installiert werden. | Ja

Hinweis. Für jedes Gerät, steht die Liste der unterstützten Betriebssysteme auf der offiziellen Web-Seite des Herstellers zur Verfügung.


Glossar

Adresslisten

Eine Zusammensetzung von Dateien, die Daten über ViPNet Netzwerkobjekte enthalten (Knoten, Benutzer, Arbeitsgruppen), inklusive Daten über ihre Namen, Identifikatoren, Adressen und Verbindungen. Diese Dateien werden in Administrationsanwendungen von ViPNet erstellt, die für den Aufbau der Struktur und die Konfiguration des ViPNet Netzwerks verwendet werden (ViPNet Network Control Center, ViPNet Network Manager).

Adresslisten und Schlüssel

Beinhaltet Adresslisten, Netzwerkknotenschlüssel bzw. Benutzerschlüssel und wird vom Programm ViPNet Network Manager (in ViPNet VPN-Netzwerke) oder ViPNet Network Control Center (in ViPNet Netzwerke basierte auf der Software ViPNet Administrator) aus aktualisiert.

Authentifizierung

Der Prozess der Überprüfung der Identität eines Objekts mittels der Validierung der Anmeldedaten durch das Objekt zur Verfügung gestellt. Übliche Formen von Anmeldeinformationen sind digitale Signaturen, Smartcards, biometrische Daten und eine Kombination von Benutzernamen und Passwörtern.

Benutzerschlüssel

Eine Reihe von Dateien, die für die Authentifizierung des Benutzers notwendig sind. Der persönliche Schlüsselsatz wird in Abhängigkeit von der Authentisierungsmethode des Benutzers erstellt.

Biometrischer Generator

Eingebaute Komponente der ViPNet Software, die die Initialisierung des Zufallszahlengenerator auf der Grundlage der Aktionen des Benutzers ermöglicht.

Client

Netzwerkknoten, der entweder einen Ausgangs- oder Endpunkt für die Datenübertragung darstellt. Im Vergleich mit dem Coordinator verfügt der Client über keine Routing-Funktionen.

Coordinator (ViPNet Coordinator)

Netzwerkknoten mit installierter ViPNet Coordinator Software.

Digitale Signatur

Eine digitale Signatur ist ein kryptografisches Verfahren, bei dem zu einer „Nachricht" (d. h. zu beliebigen Daten) eine Zahl (die digitale Signatur) berechnet wird, deren Urheberschaft und Zugehörigkeit zur Nachricht durch jeden geprüft werden können. Digitale Signaturen basieren auf asymmetrischen Kryptosystemen und verwenden folglich ein Schlüsselpaar, das aus einem privaten (geheimen) und einem öffentlichen (nicht geheimen) Schlüssel besteht.

Firewall

Gerät oder Programm, das auf einem Netzwerkknoten an der Grenze des Netzwerks installiert ist, den gesamten ein- und ausgehenden IP-Traffic überprüft und Entscheidungen über die mögliche Weiterleitung des Traffics zu seinem Zielpunkt trifft. Das heißt, die Firewall dient der Verhinderung von unerlaubtem Zugriff von einem Netzwerk auf ein anderes. Die Firewall ist normalerweise für die Übersetzung der internen IP-Adressen in Adressen, auf die von einem externen Netzwerk aus zugegriffen werden kann, zuständig (Durchführung von NAT). In ViPNet werden drei Typen von Firewalls mit NAT unterschieden:

  • ViPNet Coordinator – Modus, bei welchem als Firewall ein Computer mit installierter ViPNet Coordinator -Software auftritt, der NAT für verschlüsselten Traffic sicherstellt.
  • Mit statischer Adressenübersetzung – Modus, bei dem zwischen dem geschützten Knoten und dem externen Netzwerk eine Firewall aufgestellt ist, die statische Umsetzung von IP-Adressen durchführt, d. h. die Interaktion externer Knoten mit einer bestimmten internen Netzwerkadresse über das UDP-Protokoll mit vorgegebenem Port sicherstellt.
  • Mit dynamischer Adressenübersetzung – Modus, bei dem zwischen dem geschützten Knoten und dem externen Netzwerk eine Firewall aufgestellt ist, die dynamische Umsetzung von IP-Adressen durchführt. Dabei sollte im offenen Netzwerk ein Coordinator präsent sein, der die Verbindungen aufrechterhalten kann. Firewalls dieses Typs werden eingesetzt, wenn Verbindungen zum externen Netzwerk zum Beispiel über ein xDSL-Modem aufgebaut werden, das als Router auftritt, oder wenn dazu drahtlose Geräte, GPRS-Netze oder andere Anbieter, die private IP-Adressen zur Verfügung stellen, verwendet werden.
Herausgeberzertifikat

Zertifikat, mit dessen privatem Schlüssel ein anderes Zertifikat signiert wird.

Masterschlüssel

Der Schlüssel, den der Administrator des ViPNet Netzwerks zum Erstellen von symmetrischen Benutzer- und Netzwerkknotenschlüsseln verwendet. Im ViPNet Netzwerk werden die Masterschlüssel von drei Arten erstellt:

  • Masterschlüssel für Austauschschlüssel,
  • Masterschlüssel für Schutzschlüssel von Austauschschlüsseln,
  • Masterschlüssel für persönliche Benutzerschlüssel.

Der Masterschlüssel wird mittels eines Zufallszahlengenerators erzeugt. Er wird im Programm ViPNet Key and Certification Authority vollständig vertraulich gespeichert, da die Kompromittierung des Masterschlüssels zur Kompromittierung von allen auf seiner Grundlage erzeugten Schlüsseln führt.

Netzwerkknotenschlüssel

Eine Reihe von Dateien, die für die Verschlüsselung der lokal gespeicherten Daten sowie des Datenverkehrs notwendig sind.

Öffentlicher Schlüssel

Eine Reihenfolge von Zeichen, die zum privaten Schlüssel in bestimmter mathematischer Relation steht. Der öffentliche Schlüssel ist für alle Benutzer des Systems zugänglich und dient der Bestätigung der Echtheit einer digitalen Signatur (oder Verschlüsselung).

Privater Schlüssel

Eine einzigartige Folge der Symbole, die zum Erstellen des Signaturschlüssels bestimmt ist.

Der private Schlüssel ist ein geschlossener (vertraulicher) Teil des Paars der asymmetrischen Schlüssel.

Schlüsselupdate

Bei der Veränderung der logischen Struktur des ViPNet Netzwerkes werden die Schlüssel sowie die Adressenlisten der betroffenen Netzwerkknoten geändert. In diesem Falle ist eine Aktualisierung der o.g. Informationen notwendig. Diese Aktualisierungen werden vom ViPNet Network Manager oder dem ViPNet Network Control Center versendet.

SQL-Server

Der Datenbank-Server, der durch die Software Microsoft SQL Server verwaltet wird.

Transportmodul (MFTP)

Die Software-Komponente für den Informationsaustausch innerhalb des ViPNet Netzwerkes.

Übergeordnete Zertifizierungsstelle

Zertifizierungsstelle, die in Bezug auf einer anderen Zertifizierungsstelle im hierarchischen System der Partnerbeziehungen zwischen den Zertifizierungsstellen übergeordnet ist. Dabei kann sie einer anderen Zertifizierungsstelle untergeordnet sein, falls sie keine Hauptzertifizierungsstelle ist.

Untergeordnete Zertifizierungsstelle

Zertifizierungsstelle, deren Administrator-Zertifikat durch eine übergeordnete Zertifizierungsstelle bestätigt worden ist.

ViPNet Administrator

Software-Suite für die Verwaltung von ViPNet Netzwerken, beinhaltet ViPNet Key and Certification Authority und ViPNet Network Control Center.

ViPNet Key and Certification Authority (KCA)

Eine der Software-Komponenten von ViPNet Administrator.

ViPNet Network Control Center (NCC)

ViPNet Network Control Center ist ein Programm, das Teil von der ViPNet Administrator Software ist. Es ist zum Erstellen und Steuern der Konfiguration des Netzwerks bestimmt und ermöglicht die Lösung von folgenden Hauptaufgaben:

  • Erstellung des virtuellen Netzwerks (Netzwerkobjekte und ihre Verbindungen, einschließlich Partnernetzwerkverbindungen);
  • Änderung der Konfiguration des Netzwerks;
  • Erstellung und Versand der Adresslisten;
  • Versand der Netzwerkschlüssel und Benutzerschlüssel;
  • Erstellung von Informationen über die Benutzerverbindungen für ViPNet Key and Certification Authority;
  • Festlegung der Benutzerrechte auf den ViPNet Netzwerkknoten.
ViPNet Netzwerk

Mit Hilfe von ViPNet Software aufgebautes logisches Netzwerk.

ViPNet Netzwerk Administrator

Person, die für die Verwaltung des ViPNet Netzwerkes verantwortlich ist. Sie hat Zugriff auf den ViPNet Network Manager oder ViPNet Network Control Center und (oder) auf das ViPNet Key Certification Authority.

ViPNet Netzwerkknoten

Computer mit installierter ViPNet Software.

Zertifikat

Ein Digitales Zertifikat (auch Zertifikat oder Public-Key-Zertifikat) sind strukturierte Daten, die den Eigentümer sowie weitere Eigenschaften eines öffentlichen Schlüssels bestätigen. Durch ein digitales Zertifikat können Nutzer eines asymmetrischen Kryptosystems den öffentlichen Schlüssel einer Identität (z. B. einer Person, einer Organisation oder einem IT-System) zuordnen und seinen Geltungsbereich bestimmen. Damit ermöglichen digitale Zertifikate den Schutz der Vertraulichkeit, Authentizität und Integrität von Daten durch die korrekte Anwendung der öffentlichen Schlüssel.

Zertifikatsperrliste (CRL)

Liste von Zertifikaten, die vom Administrator der Zertifizierungsstelle gesperrt wurden und zum gegenwärtigen Zeitpunkt ungültig sind.

Zertifizierungsstelle

Im weiten Sinne ist die Zertifizierungsstelle eine Organisation, die die Zertifikate der öffentlichen Schlüssel sowie Zertifikate anderer Geltungsbereiche ausstellt. In den ViPNet Netzwerken werden die Zertifikate in ViPNet Key and Certification Authority (KCA) ausgestellt.

Im Sinne des ViPNet Netzwerks wird mit dem Begriff „Zertifizierungsstelle“ auch ein Netzwerkknoten mit installiertem Programm ViPNet Key and Certification Authority bezeichnet.